Lost Planet 2 Black Screen

Has anyone had any luck getting Lost Planet 2 to work via lutris?

Used the liveless fix (Xliveless - DLL files - PCGamingWiki PCGW Community), which works perfectly on a friends Windows machine. Limited the CPU cores (everything from 2 - 6), made sure, the dependencies where installed. I tried every Wine and Proton version available (from 7.1 to ge 8.22).
In wine config, tried every windows version from XP to 10.

Launcher starts fine, with the option to choose dx9 and dx11 versions, bot no matter which one I choose, I get a black screen, no sounds, no error message. Black Screen remains until I ALT+F4 and force quit the app.

Does anyone know of a launch parameter or something similar I am missing? Has anyone gotten this to work?

running: Ryzen 7 6800H, Radeon RX 6850M XT, Mint Cinnamon 21.2, Lutris 0.5.14

I am starting to suspect it has something to do with AMD GPUs. The game ran fine on a friends RTX 2070. Meanwhile, no matter how I configure wine, my RX 6850M XT still only gets a black screen after the launcher. The only mention of issues with AMD GPUs I found is a steam thread about disabling cores if you have more than 6, but I already tried that. Does anyone know what I’m missing?