Back to the main site

Lord of the Rings Online

Good evening community and happy Easter!
I have problems starting the game mentioned in the subject as a 64Bit client.
After logging in and starting the game, I only see a lot of colorful boxes, I hear the sound, but the graphics are totally broken.
Does anyone have the game running as a 64bit client?
many thanks

Ubuntu Gamepack 20.04
gui: lxde

Can you give more details on your setup per the pinned post? I installed and ran the 64 bit client on my setup successfully (5.11.11-xanmod1 kernel, lutris 6.4 default wine runner, Windows 10 set in the wine configuration, dxvk 1.8.1 and 64 bit client selected in the launcher, amd gpu). The launcher is a bit annoying, had to restart 5 times before I could get into the game first time.

1 Like

Hello,
thanks for the reply.
Kernel: 5.8.0-48 generic
Lutris: 6.4-x86_64
DXVK: v1.8.1L
Wine Config: Windows 10
Desktop Gui: LXDE
Lotro Launcher is set to 64bit

i get this screen when launching lotro

IMG_4024

i started Aoe2 over Steam, and have this same picture in yellow…

Can you run the following in a terminal (just gets the basic system info including the graphics card and driver versions) :

inxi -GSC -xx

Also can you start lutris from a terminal using lutris -d and then start the game. When the games starts and you get this screen, are you able to shut the app down or do you need to reboot the system?

1 Like

System:
Host: robot Kernel: 5.8.0-48-generic x86_64 bits: 64 compiler: N/A
Desktop: LXDE 0.10.0 wm: gnome-shell dm: GDM3
Distro: Ubuntu 20.04.2 LTS (Focal Fossa)
CPU:
Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen
L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 127992
Speed: 4003 MHz min/max: 2200/4000 MHz Core speeds (MHz): 1: 3997 2: 3992
3: 3994 4: 3802 5: 3942 6: 3992 7: 3993 8: 3994 9: 4005 10: 3996 11: 3999
12: 3993 13: 3992 14: 3990 15: 4000 16: 4000
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: CardExpert
driver: nvidia v: 460.67 bus ID: 26:00.0 chip ID: 10de:1e82
Display: x11 server: X.Org 1.20.9 driver: nvidia compositor: gnome-shell
tty: N/A
OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67
direct render: Yes

yes i can shut the app with Alt+F4
I found the problem, when I activate VKBasalt I get the faulty picture.

Goverlay starts normally, apparently I have an error in it.
Do you know that too?

many thanks

I have vkbasalt disabled - never found a use for it so that is a new one on me and enabling it with a few select enhancements had not effect on the game in my system. Anyway, glad you got it sorted!!!

1 Like

I tried VKbasalt because I like to use Reshade. Reshade starts but unfortunately I cannot select or activate a preset.
thank you for your help and support

grafik
i can not activate 64-bit
when i type in Consol - file Lotrolauncher.exe , i get the answer that the .exe is 32 bit
also reshade x64 dont get started.

When I look in Games/LotR/drive_c/Program Files (x86)/StandingStoneGames/The Lord of the Rings Online/x64, there is a 64 bit client. When I run the game and select the 64 bit client (push the 64 bit client button which does not change and then select save) I can see the lotroclient64.exe in my active processes.

Screenshot from 2021-04-06 11-35-28

1 Like

thanks for your answer, i have no lotroclient64.exe in my task-manager.
i found the UserPreferences64.ini, so i think the 64 bit client is running.
Reshade 64bit dont work, but i got vkBasalt working with Reshade Effects.

thank you jhu for your help!