Lord of the Rings Online WINE Standalone DXVK + Esync version script

FYI, as of 2022/05/25, The Lord of the Rings Online made a breaking change to user installations involving the game UserPreferences*.ini file(s) if you run a 64-bit client. The symptom is that the Launcher (login) panel comes up, but once one attempts to enter a game world (which opens the game client), the launcher closes, and the game client does not start. The Lutris button transitions back from “Stop” to “Start” as it is aware the game programs died/quit.

The problem involves a broken edit of the game .ini files (failure to properly merge UserPreferences64.ini with a now-unified UserPreferences.ini).

Fixing the .ini file is relatively simple and described here:


Less obvious though, is a related problem for those that have DXVK enabled as one of the scripts posted here does:

I was able to fix the game launch in Lutris simply by disabling the “Enable DXVK/VKD3D” Runner Option in the Lutris Configure option found in the pop-up menu attached to the Play button.

The manual edits to the .ini file weren’t needed in my case, but apparently are for others. In my case, simply turning DXVK off made it so the client would start, re-prompt whether I wanted to use DX11, and when I clicked Yes, the program inserted the missing UserPreferences.ini entries needed by the 64-bit client. Nevertheless, if the edits are done, they restore the graphics configuration in use prior to the update.

No telling if they will fix what they broke, but until they do, the DVXK + ESYNC script is probably going to frustrate folk.

Disabling DVXK is needed regardless whether the .ini file is edited. Re-enabling DVXK after the games starts working again will re-break it.


The forums now contain a report from a non-Lutris user, that setting vulkan-1(.dll) to builtin in the Wine Libraries setup was helpful.


I have confirmed that I can leave “Enable DXVK/VKD3D” enabled if I add “vulkan-1” to the Wine Configuration Libraries list and set it to ‘‘Builtin’’.


Where can one find the Wine Config. Libraries list?

In Lutris, there’s a Wine Bottle button widget. Push it, pick Wine Configuration, then pick the Libraries tab. Check the list for vulkan-1. If it is not in the list, there’s an input box, so type vulkan-1 in it, then push Add. Click-select vulkan-1, push Edit… and select Builtin (Wine). Push OK, and OK again.

1 Like

Thanks! :smile:

The claimed fix for DXVK doesn’t work here. Still must disable to run the game even after telling wine to use the built-in vulkan-1 library. But this is a hybrid mess. Devuan 3.1 with Lutris installed from the ‘external’ SUSE repository. Maybe if it was using the Lutris from the Devuan/Debian repositories it would work. I’ve been planning a reinstall for a while now. Looks like a good time to try it. :slight_smile:

OK, after trying again I got it to work. Not sure why it didn’t work before. It certainly performs better with DXVK enabled. I can see it in the frame rate and on the CPU meters of my Gkrellm. As a bonus, I tried the same thing with Star Trek Online, which has also been misbehaving. This also loads and runs properly with the vulkan-1 library set to builtin only.

1 Like