Back to the main site

LoL + Dual monitors

Hi, I can’t figure out how to position the game window. When the game goes full screen, it’ll go right in the middle (half’n’half) of my monitors, rather than on my main monitor. How can I make the game stick to just one monitor in Lutris?

That’s weird, that’s an issue you would have with SDL 1.2 games usually.
Are you running the Nvidia driver + Twinview? Also, what WM are you using?

What I usually do when Wine games don’t let me switch monitors easily is using a wine virtual desktop of the size of my resolution. That way, I can drag the virtual desktop in Gnome Shell and not the game itself, makes playing games on the TV much easier and fixes issues with games that crash when alt-tabbing.

VM? VM for me stands for VirtualMachine :stuck_out_tongue: I guess that’s not what you’re asking as playing games inside a VM would give very poor performance :stuck_out_tongue:

Running Wine with virtual desktop almost solves my problem, except for it being slightly off-set due to my KDE panel up top. Which makes the window cut off slightly at the bottom.

No, not VM, WM :smiley:
Anyway, you already answered in your reply and you seem to be using KDE, so the WM would be Kwin.

I don’t know about Kwin specifically but with Mutter (Gnome Shell) the wine virtual desktop will be full screen if it matches the screen’s resolution. Anyway, Kwin is far more configurable than Mutter and I’m pretty sure there are options to remove window decorations and set them to full screen.

1 Like

Cheers, you’ve brought some light on where I should be looking for settings. I’ll keep trying ^^

I have the same Problem with many games, what I do is let lutris (under configuration) turn off the wrong monitor when the game starts, so the game has to start whre I want it to be.
Obviously that’s just a workaround.

The only games that should benefit from the “turn monitors off except” option are old SDL 1.2 games. Any other game should work without this tweak, with at most maybe a little configuration on the Window Manager side.

Is there a good answer for how to fix this? I have the same issue with KQ games (AGDI remakes). I’ve got this configuration: https://pastebin.com/TTi17iUb
I don’t see an option to “turn off monitors” anywhere in any settings, global or per-game. There are a lot of other options to tweak, and being new to Lutris, I don’t know where to begin.
The game’s runner is “Adventure Game Studio (Graphics adventure engine)”
Setting “Fullscreen” to false has no effect, for example.