[LoL] Critical error whenever starting the game

In League of Legend, as of today’s patch (it worked yesterday),
I can start match making, but when the game starts, I get a critical error.
And every time I try to reconnect I get the same error.
I don’t know what more information I can provide, but I assume I am not the only one with this error right now.


I have the same problem, I’d like to fix it

I have the same issue. I already tried to reinstall without much success unfortunately. When it crashes, it asks if we want to write down the memory dump. Even though I don’t think it will be much of a help. Any suggestion of fix is welcome :slight_smile:

Same problem here. I tried TFT and Practice Tool to test and neither are working.


I don’t think anyone has it working with any version of wine currently. Some other comments also on : https://www.reddit.com/r/leagueoflinux/comments/dfdik3/crashing_ingame_on_patch_920_a_critical_error_has/

I guess it’s “other games” time. Stay strong.

Like Tristana would say : Once a linux user, always a linux user ! :wink:

1 Like

Came to make sure this was mentioned. I see that it is. A big thank you to whomever is at work on this in the community.

Instalei ubuntu, estou feliz em aprender esse universo linux, mas fiquei muito triste quando o lol parou de rodar. Sou obrigado a ter windows so pra jogar lol…

Talvez seja a hora de retornar ao Dota 2 e valorizar empresa que se preocupa com a comunidade linux.


WINE bugtracker: https://bugs.winehq.org/show_bug.cgi?id=47915

(the reddit thread is already linked. See the above link to the post)

LoL bug report: https://boards.na.leagueoflegends.com/en/c/bug-report/rJNQJbHh-crash-game-launch-crashes-on-920-under-wine?sort_type=recent

seems like to work for them

Is this WINE version soon available via Lutris, too?