Back to the main site

locale.Error: unsupported locale setting

Hello there,

I’m new to linux community and I wanted to check if some of my favorite games run here or not, well color me surprised when I found they do run with the help of lutris. So I intalled it, but there seem to be an error.

(base) [shan@Kreta ~]$ lutris
Traceback (most recent call last):
 File “/usr/bin/lutris”, line 27, in <module>
   locale.setlocale(locale.LC_ALL, locale_name)
 File “/usr/lib/python3.7/locale.py”, line 604, in setlocale
   return _setlocale(category, locale)
locale.Error: unsupported locale setting

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
 File “/usr/bin/lutris”, line 29, in <module>
   sys.stderr.write(“Unsupported locale %s. Try running with LC_ALL=C.\n” % locale_name)
TypeError: not all arguments converted during string formatting

Did I did something wrong? Please help!
Oh and I installed it on Manjaro KDE (currently using deepin) through pamac.
And if system spec are needed that would be:
CPU: Ryzen 5 2600
GPU: GTX 1060
RAM: 16 gigs

You might want to try a different Desktop GUI than KDE, I have read there is currently a possible incompatibility between KDE and Lutris. I would suggest installing Gnome onto Manjaro. You can setup Manjaro to run both KDE and Gnome. What you want to do is install Gnome and after that when you login to Majaro there will be an option to either run KDE or Gnome, as to how to set this up, I can’t help you there because I haven’t worked with Manjaro.

type this on terminal LC_ALL=C lutris or add it to the exec line in the .desktop file. exec=LC_ALL=C lutris %U

1 Like

i’m running KDE Neon
thanks this command works for me. sadly i have to go that route :confused:

I had the same problem on Kubuntu. Turns out the system was missing language support. It notified me about Incomplete Language Support after a few minutes of login to the desktop. I installed the missing language and Lutris launches normally.