Local script wants runner specified

When trying to run a locally written script with no entry online:

“Missing field “runner” in install script”

I can find scripts online where runners are specified like ‘runner: “linux”’ or ‘runner: “winesteam”’ but never just “wine”, which is how this program runs. Putting just “wine”, ‘wine’, or “windows” in runner under the game section, does not work.

What would I write, where, to let Lutris know that it should be run through wine, without steam?

you need to specify a version of wine (found in the wine runners list – lutris>manage runners>wine> manage versions)

you then list the runner like so:

version: staging-2.21-x86_64

And there’s no way around that? Because that makes the script way more limiting

for wine games that arent in steam if you want it to use wine (any version), you dont need to specify a runner, you just need to have wine installed on the system. if you just want it to use the system’s wine version you also dont need to specify the wine: section that I explained above

Without a "runner: " specified in the local .yml script, I still get “Missing field “runner” in install script”

EDIT: Even specifying a specific wine version, like so:

    version: staging-2.13-i386

says I do not have “runner:” specified. I even tested it with the popular Overwatch script, same issue. Default behavior when runner isn’t present should be default to wine, but that’s not the case when installing locally. Definitely a bug.

I am having the same problem. Every script I run tells me Missing Runner. I have Wine installed but it will not run.

richard_and_alice.yml (463 Bytes)

Here is an example script that works with GOG installer of Richard and Alice.
Uses default wine version specified in Lutris Wine’s runner options.