Back to the main site

Life is Feudal: Forest Village


#1

Can someone please write an installer for Life is Feudal: Forest Village?
I just bought it from steam summer sale. I tried to install it and found that lutris didn’t know it was released in May of last year. I guess not to may Linux gamers play it yet.


#2

Made one could you test it? You need to have a Vulkan capable GPU and Vulkan libs installed on your PC. Please review our DXVK wiki page before installing.


#3

I discovered wine was no longer installed after upgrading to Kubuntu 18.04! The instructions at https://wiki.winehq.org/Ubuntu do not work. I suspect one or more bad files on their website.
Last error message was “Unable to find package winehq-staging”. The was also an unexpected file size error.


#4

An update via discover fixed the wine installation but this installer fails. It is a 64-bit game and it tries to a 32-bit wine prefix. Manually updating the wine version to 64-bit gets all the way to getting steam running, but then the game gets stuck at the start. missing mscore.dll


#5

I tried reinstalling and it worked this time. At first, the mouse cursor was messed up. The installer created two version. I deleted one then tried the game again. It seems to work correctly now. You might want to look at the script to see why it installs two entries in Lutris. I will test further later. Thanks for making this installer.


#6

I was just testing the game. I was playing the tutorial. The map angle is such that I can not see everything. The mouse is a little sluggish. The game just crashed bringing steam down with it.


#7

Rats, I bought an NVIDIA GT730. The GTX version supports Vulcan But the GT version - code-named GF108-, does not. I’ll deactivate Vulcan and see if it works.


#8

I switched to the latest 64-bit wine staging, turned off Vulcan and turned off process monitor. In the game options, I selected the mouse lag option. The game seems to work except for some slight mouse sensitivity. I will look later in options to see if I can adjust that. So far the game seems to work. I don’t know why so many games crash with the process monitor turned on. Maybe Strider needs to look at the process monitor code.


#9

As of today steam no longer runs! When I run the game Steam starts and immediately goes to the zombie state!