Legoland crashing upon opening the map

Hi there,
I’m currently trying to get Legoland (2000) to run. So far I had minor success but now I’ve hit a wall.
Currently I’m having two minor issues:

  • The game crashes whenever it comes to an end of a cutscene (I consider this minor, simply skipping the cutscene by pressing ESC is enough of a workaround for me)

  • The game always crashes when I try to open the map (this one is a real bother as I cannot continue with the tutorial without succesfully opening the map)

With my little knowledge I have from reading the logs it would appear to me that the game is running out of RAM, hoever as can be seen in the “enabled Output Debug Info” The game is requesting memory and isn’t using it up when it’s crashing. I suppose this must have something to do with it beining a 32-bit programm, beiing in conflict with the underlying 64-bit hardware, however I am unsure how to fix this. Any help would be appreciated!
I checked that I have the needed vulcan drivers aswell as all the fitting dlls for my igpu like the audio codecs and .net Framework (at least to my knowledge)

required Information:

  • Lutris issue report

  • Lutris debugging output (Very curiously I run into different problems running Lutris this way. The game will only start after a second restart and it will crash immediatly when skipping a cut scene. Both behaviors are not happing when running Lutris normally.)

  • Log Output (This is the log info with the Runner Option > Output debug Info “enabled”)
    Log Output (This is the log info with the Runner Option > Output debug Info “disabled”)

To round this all off, here is my system info:

Vulkan support: YES
Esync support: YES
Fsync support: YES
Wine installed: YES
Gamescope: YES
Mangohud: NO
Gamemode: YES
Steam: NO
In Flatpak: NO
OS: Fedora Linux 40 Workstation Edition
Arch: x86_64
Kernel: 6.8.8-300.fc40.x86_64
Desktop: GNOME
Display Server: wayland
Vendor: GenuineIntel
Model: Intel(R) Core(TM) i7-10610U CPU @ 1.80GHz
Physical cores: 4
Logical cores: 8
RAM: 15.3 GB
Swap: 8.0 GB
Vendor: Intel
OpenGL Renderer: Mesa Intel(R) UHD Graphics (CML GT2)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 24.0.6
OpenGL Core: 4.6 (Core Profile) Mesa 24.0.6
OpenGL ES: OpenGL ES 3.2 Mesa 24.0.6
Vulkan Version: 1.3.280
Vulkan Drivers: Intel(R) UHD Graphics (CML GT2) (1.3.274)

Thanks for any help already,

1 Like

Always interesting trying to run old titles :slight_smile:
I can’t see an installer on Lutris, so did you create a prefix and import it?

Although it looks like a driver crash, you might want to start by building a new WINE prefix and installing some older DirectX/.NET support, and running it with WINE initially.

Whilst you can make a 32-bit WINE prefix, most things run okay in a 64 bit prefix, unless you have issues like the installer is 16-bit :slight_smile:
The only other thing I can suggest is that some graphics options are a bit quirky on older titles - vsync, transparency, oldskool antialiasing, triple buffering - to name a few. Worth trying running it in software mode or windowed mode as well, if it supports it, just to narrow down the fault.

Edit: A quick search also tells me there’s an alternate 64 bit installer someone wrote that is linked from pcgaminingwiki, and some tips running an earlier game - Lego Island - that might work on this title.

Hi, yes it’s a journey to be sure!
yes, I created a custom 32 bit prefix for it via Winetricks.

Hmm I was hoping to avoid having to run Wine directly, I don’t quite feel comfortable enough in the terminal yet :see_no_evil:

I tried installing it with the 64x installer, but it always fails and gets stuck

I will definitely look in into the graphics options and Lego Island page. Thanks for the help :slight_smile: