League of legends starts and closes in a loop

First of all, hi everyone, i know that this post is similiar to the one submitted here
but i have a different story.

I installed lutris without any problems, installed the OpenGL script from the site and then i tried to open it, but it keeps just closing and opening in an infinite loop. Unlike the guy from the other post I’ve only installed the OpenGL version , not the directx one.

Hope Someone could help me.


EDIT: forgot to mention my specs and distro
Distro: Manjaro KDE 17.0.5
System: 64bit

It seems that the “loop” has finished, now its downloading the updates. Lets see if it goes well.

Aaaand now…its stuck like this, tried restarting but nothing much.

1 Like

The exact same thing happened to me. Game kept reopening in a loop and after a few times of closing and starting the game again I managed to get to the launcher which began patching. However, after the first update I too got stuck like the screenshot in EDIT3 posted by lazzeking.

Edit: Antergos Linux x86_64, 4.13.4-1-ARCH kernel.

1 -new wine prefix
2 - wine staging
3- add msvcp140
ready to play/install

The new updated installer should now fix this problem. (it’s basically what @avbsynless said, in a script).

i helped to make the new script, works perfect! go test! :smiley: