League of Legends / Riot Client install stuck

good morning,
for over a month i can’t get league to install, the riot client installs without issue, but as soon as the league download itself reaches 99%, it suddenly jumps back to 0% and keeps ‘infinitely downloading’ with a speed of 0.1kb/s. Closing the Riot Client (finishing the installation for lutris) and opening it up again results in the install being stuck from the beginning.
Lutris issue report:

Lutris -d output:

does anyone have any idea how to fix this?
thanks in advance

Game Logs after opening it and closing it:

(in an extra answer because forum won’t let me post more than 2 links at once)

Go to the game in lutris, right click->configure->system options tab->enable Show advanced at the top.

Locate the vulkan ICD loader field and make sure it is not set to unspecified, but set to match your GPU (eg RADV or nvidia proprietary).

Your lutris -d is 404 :frowning:

I had this same issue and asked for help on GE Discord, got this helpful response from user named ginolegigot:

i think the issue
is one common for nvidia users
if u check the processes either in your terminal with “ps -ef” or whatever the gui u use, you might see a process named DXSETUP.exe (edited)
kill it and the download should succeed
got the issues for various games with steam where dxsetup process freezes

1 Like

man you saved my entire afternooon i tried anything and this worked!