Back to the main site

League of Legends OpenGL problem, "A DirectX error has occurred"


#1

I installed the OpenGL version of League of Legends on November 2nd. All seemed to work well until last night, when League patched. I am now not able to connect to games. It gives me this error, “A DirectX error has occurred and League of Legends cannot start. Please make sure your video card is using the latest video drivers from the manufacturer.”.

I am playing on an older PC that I have Linux Mint installed on. It’s an intel integrated graphics card. IDK why it says directx when I’m using opengl version.

Have tried a fresh re-install, have tried different Wine versions for LoL, and have tried different directx versions in wine config.

Any fix/suggestions?


#2

This is a problem for few windows users and opengl users
Rito f***** up OpenGL with this patch
Delete the config file(it will redownload automatically) in the riot games folder or just get into it and set
x3d_platform = 0 under GENERAL

It probs get graphical errors such as few hub errors and the whole map being dark, but jt should be playable if you really really really want to


#3

That didn’t work, tried deleting and using x3d_platform = 0 as well as x3d_platform = 1


#4

I’ve run into the same problem today, I created both scripts. Have not found a workaround for it yet.

edit: resolved. x3d_platform=1 doesn’t work any more for now. have to use dx9, gallium nine is also broken. setting the game fullscreen also doesnt work, so:
remove x3d_platform=1, and set WindowMode=2


League doesn't want to go fullscreen anymore (it affects performance)
#5

I did that, and I can now go fullscreen however my performance is really low… I used to have 60 fps minimum but now I’m more around 30 fps, whatever the graphics options are.

Do you have any suggestion of what I can do to increase this value or am I doomed while gallium nine is broken?


#6

Have you tried updating mesa? Or update opengl.

I used to get like 20 and after reinstalling lubuntu 7 times all I did was update mesa and opengl right after and got 50+
I have celeron integrated graphics with maximum cap 1.7 ghz so you should be better


#7

gallium nine seems to be working again for me with a self compiled version from wine-gaming-nine on the arch AUR. opengl still broken.


#8

for anyone that was using opengl, can you try using x3d_platform=4 in game.cfg?


#9

GloriousEggroll7d
for anyone that was using opengl, can you try using x3d_platform=4 in game.cfg?

Using wine-2.21 (Staging) for Ubuntu 17.10
After removing all of the Mesa options,

export MESA_GL_VERSION_OVERRIDE=4.5COMPAT
export MESA_GLTHREAD=TRUE
export VBLANK_MODE=0

x3d_platform=1 will cause the crash, x3d_platform=4 seems to allow it to boot the game, although performance is noticeably slower.

I would prefer to avoid using DirectX, CSMT, GalliumNine as much as possible.


#10

ignore the previous post. x3d_platform=4 just boots the game in directx again. Opengl is still broken on league atm. I;ve been using gallium nine and locking the fps at 60


#11

That’s actually really odd then, because I thought I was running the game on OpenGL with x3d_platform=4 - all the associated problems, slow FPS and lack of Fog of War, I had with DirectX didn’t happen on x3d_platform=4

Yeah, nevermind - it’s DirectX. A lot of the problems I had with DX back then seems to be fixed now.


#12

Hey there,

I recently switch to Linux (Ubuntu) cause i was tired of Windows (already tried Mac also) & as a big LoL player thats one of the first thing i installed on it :smile:.

So I decided to sign up there just to let you know that OpenGL still works u just needed to add x3d_platform=1 into your game.cfg.

Note that you also need to set somes additionals tweaks to get it work on MESA (Intel/AMD) setup.

I compared DirectX & OpenGL perf & in my case (Nvidia 700m series) I saw a huge FPS & stability improvement with OpenGL so dont hesitate to try OpenGL again :slight_smile:.

Cya on the rift :wink: .


#13

Install the latest version of Microsoft DirectX. Chances are, upgrading to the latest version of DirectX will fix the d3dx9_39.dll not found error.
Check this website for more solutions


#14

Complete Solution:

Press “Windows + R” and enter “dxdiag” to run the DirectX Diagnostic Tool. Open the “Display” tab to see the status of Direct3D and other graphics components in DirectX.

Read the “Notes” box to learn about any errors with Direct3D.

If DirectX is installed correctly, it will read “No problems found.”


#15

Move to the folder:
League of Legends/Config/
Delete the file ‘game.cfg’ and ‘input.txt’
Relaunch the game, try to spectate someone.
IF that still doesn’t work, move to these two folders:
League of Legends/RADS/projects/lol_game_client and lol_game_client_en_us
Delete both of them.
Then run the repair option in the launcher, by clicking the cogwheel in the upper right hand corner.
Check for other methods here