League of Legends not working anymore

Hello guys, i hope someone can help me. I have the problem, that league stopped working like 2 weeks ago. I had a working installation with the lutris-ge-lol-6.16-4-x86_64 runner, where i only had the problem of the corrupted DXVK cache from time to time, even tho i set the environment variables to not use the cache, but when it happened, it always was fixed by toggling dx9-legacy mode once.
But now everytime i start a game, i just have a blackscreen. Toggling dx9-legacy mode does nothing.

Then i saw there is a new version of the lutris installer script and a new runner (lutris-ge-lol-7.0-2-x86_64) available, so i did a fresh install of the game. When installing it opened the windows of the riot client installer, where you can say “install” or “advanced options”, but after clicking install and downloading/installing the game, the login window didn’t show up. Only the riot client icon appeared in the system tray. I was then able to complete the installation by right-clicking on that icon and exiting the client. But now when i start the freshly installed game, the riot client won’t show up, only the icon in the system tray shows up. I tried using the ge-lol7.0.1 runner, but it produces the same result.

Log output of starting the new install (riot client won’t show up): https://pastebin.com/3Cji24Jw
Log output of the old, previously working install (let it run until i got into a match, which resulted in black screen again): old-install-output - Pastebin.com

Thank you very much for everyone who can help me with this.

1 Like

riot client always shows for me after a delay, but once ive used it to open the league client i have to close the riot client to be able to enter a game, otherwise i also get black screen. it’s weird, but consistent

Do you mean just close the client, or exit it completely? I tried to exit the client, but it shows a message that league is still running and the riot client can’t be exited. Then the riot client “closes” itself into the system tray. Sadly it didn’t work and i still only have a black screen.

The issue has been resolved by some updates today.
But still only the v6 runner is fixed, v7 still won’t even open.