League of Legends installer takes forever

Hello, I’m sure you must’ve gotten this a gajillion times, I can’t find it though so:
I’ve been meaning to install LoL through Lutris on my ubuntu 16.04 LTS T420 ThinkPad, but when the client goes for the huge download, it’s all very smooth until it hits around 32%: the size and download speed get replaced by “applying patches” when I hover over the progresslu bar, and each percentage takes about 20 minutes now. I actually left this on for quite some time, but at 56% it finally seemed to stop downloading.
Appreciate any help and feedback (total Linux noob) and if you need any more info or something just let me know and I shall post it!

I got stuck when installing League via vanilla Wine (via this awesome guide) and, to get it to work, I transferred the Program Files from a friend’s Windows installation. The Lutris installer worked for me though, I left it to install overnight. Disk write speed may be an issue - I think it was my worse laptop that I had trouble with and that had an HDD, my current computer has an SSD.

LUL I’m on an SSD too
But might have to try copying it from my friend…

no dude dont try copying from a friend (if they are windows ) if you do you would have to change in the configuration file from ‘windows’ to ‘linux’ i think.

After a few hours it worked on a dual boot on usb 3.0 on my 2014 chromebook. It should work on your thinkpad.

Patience my lad

Eh, I might as well mention, I left it installing during the day and it somehow worked, not ideal but there we go :slight_smile:

1 Like

just watch out ps axf |grep defunct
and close the defunct process with kill -9

than the installer will finished the game and you can start it! Works for me on Ubuntu 17.10