League of Legends gets stuck after install

Hey! I’ve been trying to install LOL with Lutris (OpenGL version), but the game gets stuck on a yellow bar and never loads up. I’ve already tried to install the DX9 version, with no success too. I don’t know what else to do. Hope you guys help me find a solution! :metal:

just replied to this on reddit.

make sure you have wine and wine dependencies installed on your system

Antergos/Manjaro/Arch derivatives (enable multilib in pacman.conf):

sudo pacman -Sy
sudo pacman -S wine-staging
sudo pacman -S giflib lib32-giflib libpng lib32-libpng libldap lib32-libldap gnutls lib32-gnutls mpg123 lib32-mpg123 openal lib32-openal v4l-utils lib32-v4l-utils libpulse lib32-libpulse alsa-plugins lib32-alsa-plugins alsa-lib lib32-alsa-lib libjpeg-turbo lib32-libjpeg-turbo libxcomposite lib32-libxcomposite libxinerama lib32-libxinerama ncurses lib32-ncurses opencl-icd-loader lib32-opencl-icd-loader libxslt lib32-libxslt libva lib32-libva gtk3 lib32-gtk3 gst-plugins-base-libs lib32-gst-plugins-base-libs vulkan-icd-loader lib32-vulkan-icd-loader cups samba dosbox

1 Like

Hey man, thanks a lot! It worked! It was an dependency issue :smile: