Back to the main site

League of Legends Game Page and Home Updates

Hey gamers,

Due to new user restrictions links have been removed. Please view on Gist

First off I love this program and it makes playing League of Legends on Linux a breeze. That said the game page and assets could use a little updating and a face lift.

Game page for reference: Moved to Gist

Things I would like to update:
View on Gist for inline images and links

  • Change Wine HQ link to Moved to Gist
  • Remove outdated screenshots in slider 0-3
  • Lutris homepage slider image to Moved to Gist
    • New(left) vs Old(right) Moved to Gist
  • Update game banner to Completed

As for removing the screenshots, League went through a big graphical overhaul around 2015 and images [0-3] do not reflect the current art style of the game.

The current listed Wine HQ page is marked as obsolete and the user rating of “Garbage” is far from accurate. Not sure how Lutris pulls the status but would be nice to have that reflect the newer revision on the current thread.

I tried to submit the new game banner on the game page but it isn’t in my “Submitted contributions” anymore after I submitted some additional changes for other games. Hopefully they can update that for me.

I’ve already reached out on Discord and had the game icon updated to the current design.

I appreciate everyone’s work and am open to suggestions or changes to my proposals.
Thanks!

downthecrop#8003 on Discord

It is actually garbage at the moment, as commented on in the gist, currently it does not work.

Just played 6 games today Wine version 4.2…

I can’t log in, sometimes I can but it’s extremely temperamental, even after commenting out the line suggested here. Any ideas or do you have to concede that it’s near-Garbage for at least one person (me) at the moment? :slight_smile:

(applies to Wine tkg-4.2 and esync-3.14)

I did some further research on this and made a post about it on r/wine_gaming in the hopes of finding a solution. TkGlitch, the man himself was quick to reply and point out a ticket on WineHQ was already open and and it seems to be a Debian-only issue. A different WINE version isn’t going to help and a patch has been posted on the bug-page (linked in the reddit post too). I myself found that using WireGuard to connect to the internet also consistently lets me start the install procedure (and presumably) play. Exiting and then starting it back up seems to pose an issue for League, unfortunately. If I find something on that I’ll post it on the bug-page, so keep an eye on it.

For what it’s worth: I think it’ll be fixed in a future update (be that for WINE or Debian packages related to connection and DNS handling). So there’s that consolation.

EDIT: So fun thing. I figured I’d retry and fiddle with the lutris settings, well… Whaddaya know. Right click League in Lutris -> Configure -> System Options -> Adjust below values like so:

Disable Lutris Runtime = true
Prefer system libraries = false

Doesn’t help for me with the specific error visible in red text in my screenshot that prevents me from logging into League (Ubuntu 18.10)

Well, that is assuming you’re using WireGuard. Because as you can see from the bug-page, it’s got some correlation with systemd-resolved and it’s configuration (as well as the combination with other network related packages). WireGuard fixes this for me. Only then did I run into the issue of not being able to boot again, to which the answer was: setting those settings in Lutris.

And just as I posted that: https://bugs.winehq.org/show_bug.cgi?id=46704#c43

Wine Staging 4.3 includes the fix. Now it’s either waiting for TkG to add his version or otherwise patch it into older wine versions.

Today, Mars 17, the game is noticed as “Garbage”, but in fact actually works.

And a have a question : why Wine config for lol is configured for xp ? xp and vista version of lol will not be supported by Riot in may 2019.

You’re right, Win7 should simply work now, but because the Lutris builds not yet have a tkg-wine-4.3 version (which contains the fix linked above) most Linux players (Debian based distros; Ubuntu, Mint, etc.) weren’t able to play. If the Riot has fixed the issue, or it has otherwise been rectified, this should indeed be changed to “working” again.

As of Mars 20, the latest install script have the tkg-wine-4.3 version, but lol is again broken by his updates …

Can log into client just fine however loading into the game now crashes after this latest patch , anti cheat maybe ?

Nvm was crashing in Wayland, works now with X.

Still crashes on X for me for wine 4.3+; 4.2 is fine on X and wayland. (Fedora 29, Gnome 3.30.2)

There’s a comment by elika123 on the league page on lutris.net with a solution that seems to work for some people.

Copied here for posterity (click to expand)

Tell Network Manager not to manage our resolv.conf by editing /etc/NetworkManager/NetworkManager.conf, and adding the following line to the [main] section: dns=none

Restart Network Manager: systemctl restart network-manager

Now remove symlinked resolv.conf that is part of systemd: rm /etc/resolv.conf

Create a new resolv.conf (just a new text document) with your text editor of choice and add the following line: nameserver 8.8.8.8 save it in /etc/

Restart Network Manager again using systemctl restart network-manager After that your internet connection may be set to “disconnected” but you are still online.

Update via terminal sudo apt-get update and sudo apt-get update [sic; I think they might have meant to write sudo apt-get upgrade] this will reconfigure resolv.conf, after that simply restart your system.

For me League is working.

To revert the changes:

  • Remove the line dns=none from /etc/NetworkManager/NetworkManager.conf
  • rm /etc/resolv.conf
  • ln -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf
  • systemctl restart network-manager

On Mars 24, status of the game has changed to BROKEN ON OLD VERSIONS OF UBUNTU, LINUX MINT AND DEBIAN!, and install script is now with wine tkg 4.0. Wow.
I had to launch the install script to have wine tkg 4.0 installed. But i didn’t install again the game, i only changed the wine version used to wine tkg 4.0, and with updated ubuntu 18.04, the game works again.