League of Legends doesn't start - Game has quit

Hi everyone,

I’m running the latest Lutris version on Ubuntu 18.04 with kernel version 4.16.11. I re-installed League of Legends with DX9 (as OpenGL is unsupported) five times now and I still can’t seem to get any further. THe installers completes without errors, but as soon as I try to launch the game, it says ‘Launching League of Legends’, then after 3 seconds it says ‘Game has quit’. I tried running Lutris in ebug mode to get more information but I can’t see any error messages.

Debug log:

DEBUG    2018-05-23 14:09:01,896 [game]:Launching League of Legends: {'env': {'MESA_GLTHREAD': 'true', '__GL_THREADED_OPTIMIZATIONS': '1', 'DRI_PRIME': '0', 'WINEDEBUG': '-all', 'WINEARCH': 'win64', 'WINE': '/home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wine', 'WINEPREFIX': '/home/john/Games/league-of-legends'}, 'command': ['/home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wine', '/home/john/Games/league-of-legends/drive_c/Riot Games/League of Legends/LeagueClient.exe']}
DEBUG    2018-05-23 14:09:01,902 [thread]:Command env: SDL_VIDEO_FULLSCREEN_DISPLAY="off" MESA_GLTHREAD="true" __GL_THREADED_OPTIMIZATIONS="1" DRI_PRIME="0" WINEDEBUG="-all" WINEARCH="win64" WINE="/home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wine" WINEPREFIX="/home/john/Games/league-of-legends" 
DEBUG    2018-05-23 14:09:01,903 [thread]:Running command: "/home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wine" "/home/john/Games/league-of-legends/drive_c/Riot Games/League of Legends/LeagueClient.exe"
DEBUG    2018-05-23 14:09:01,904 [thread]:Storing environment variable SDL_VIDEO_FULLSCREEN_DISPLAY to off
DEBUG    2018-05-23 14:09:01,905 [thread]:Storing environment variable MESA_GLTHREAD to true
DEBUG    2018-05-23 14:09:01,906 [thread]:Storing environment variable __GL_THREADED_OPTIMIZATIONS to 1
DEBUG    2018-05-23 14:09:01,906 [thread]:Storing environment variable DRI_PRIME to 0
DEBUG    2018-05-23 14:09:01,907 [thread]:Storing environment variable WINEDEBUG to -all
DEBUG    2018-05-23 14:09:01,907 [thread]:Storing environment variable WINEARCH to win64
DEBUG    2018-05-23 14:09:01,908 [thread]:Storing environment variable WINE to /home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wine
DEBUG    2018-05-23 14:09:01,908 [thread]:Storing environment variable WINEPREFIX to /home/john/Games/league-of-legends
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
DEBUG    2018-05-23 14:09:04,314 [thread]:Start process monitoring
DEBUG    2018-05-23 14:09:04,314 [thread]:Processes monitored: LeagueClient.ex (14180:Z)
DEBUG    2018-05-23 14:09:04,315 [thread]:Processes excluded: wineserver (14183:S)
DEBUG    2018-05-23 14:09:04,315 [thread]:Waiting for processes to exit
DEBUG    2018-05-23 14:09:04,315 [thread]:Removing stdout monitor
DEBUG    2018-05-23 14:09:04,315 [thread]:Thread is no longer running
DEBUG    2018-05-23 14:09:04,315 [thread]:Restoring environment
DEBUG    2018-05-23 14:09:05,905 [game]:Game thread stopped
DEBUG    2018-05-23 14:09:05,906 [game]:Game thread still running, stopping it (state: running)
DEBUG    2018-05-23 14:09:05,909 [game]:League of Legends stopped at Mi, 23 Mai 2018 14:09:05
INFO     2018-05-23 14:09:05,910 [runner]:Runtime disabled by system configuration
DEBUG    2018-05-23 14:09:06,304 [wine]:Killing all wine processes: ['/home/john/.local/share/lutris/runners/wine/staging-3.8-x86_64/bin/wineserver', '-k']
DEBUG    2018-05-23 14:09:06,305 [wine]:	Wine prefix: /home/john/Games/league-of-legends
DEBUG    2018-05-23 14:09:06,305 [wine]:	Wine arch: win64
DEBUG    2018-05-23 14:09:06,310 [wine]:Waiting for wine processes to terminate
DEBUG    2018-05-23 14:09:06,311 [thread]:Restoring environment
DEBUG    2018-05-23 14:09:06,311 [thread]:Killing all remaining processes

Thank you for the help!

Hey !
So this is not a fix but you should be able to play if you right click on the game, click on “Run EXE inside prefix” and then select the executable (drive_c/Riot Games/League of Legends/LeagueClient.exe) :slight_smile:

If you do find a real fix, be sure to alert me. I’d be happy not to have to do that anymore haha

(this is the first issue that talks about that problem: Cannot Launch League of Legends)

Thanks for the reply, but unfortunately it doesn’t work. I believe I have an other issue.

:disappointed: sorry I have no idea then. It’s the exact same symptoms I have though, it’s crazy.

It worked for me! Now, I’m updating the game.

try to install Wine (development version) it helped for me.