League of Legends does not start after installation

  1. The file created by running lutris --submit-issue in a terminal.

  2. Output of lutris -d. Kill Lutris and run lutris -d through a terminal. Reproduce your problem and share the output.
    Output of lutris -d

this error messages:
0031:err:winediag:gnutls_initialize failed to load libgnutls, no support for encryption
0031:err:winediag:gnutls_initialize failed to load libgnutls, no support for pfx import/export

mean you don’t have all needed Wine dependencies.
To install them, follow this tutorial:

and verify you have Vulkan libraries too:
1 Like

I ran the commands for Arch Linux with the --needed flag to install only the ones that were missing and it worked!

The game opened normally thank you very much!



sudo pacman -S --needed wine-staging giflib lib32-giflib libpng lib32-libpng libldap lib32-libldap gnutls lib32-gnutls mpg123 lib32-mpg123 openal lib32-openal v4l-utils lib32-v4l-utils libpulse lib32-libpulse libgpg-error lib32-libgpg-error alsa-plugins lib32-alsa-plugins alsa-lib lib32-alsa-lib libjpeg-turbo lib32-libjpeg-turbo sqlite lib32-sqlite libxcomposite lib32-libxcomposite libxinerama lib32-libgcrypt libgcrypt lib32-libxinerama ncurses lib32-ncurses opencl-icd-loader lib32-opencl-icd-loader libxslt lib32-libxslt libva lib32-libva gtk3 lib32-gtk3 gst-plugins-base-libs lib32-gst-plugins-base-libs vulkan-icd-loader lib32-vulkan-icd-loader


sudo pacman -S --needed nvidia-dkms nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader

1 Like