Back to the main site

League of Legend's Client Freezing


#1

Hello, everyone!

It’s been 2 days since the new wine installer version of League of Legends was launched (Platinum Rate), and of course I installed it. The problem is: when I open the client, it freezes (Just the window, not my entire system). I can’t do anything, and don’t know what to do!

Can someone help me with this issue? Thank you!


#2

Yeah same here, it freezes when the “Play” button is hovered. Otherwise it works.


#3

Same here. Sometimes it freezes when the “Play” button is hovered, sometimes when I join a group, etc


#4

I had the same issue. I had to enable DXVK, and set the version to 0.63 (which isn’t an option, but it apparently downloads it). That allows me to run it, however, it suffers from awful framerate even on low settings. Trying to figure that out at the moment.


#5

same here help please :persevere::persevere:


#6

Ok, to solve the freezing problem I disabled the option to auto join the voice chat when entering a game room and set the mic activation to be a button instead of auto on voice.

I was able to join a party and play and entire game with no issues, however, the game hung up after vicroty/defeat and would not load the after battle screen or return me to the interface to start a new game. If I figure that one out I will let you know


#7

Sound like the normal Pulseaudio issues with Staging 3.13. Should be fixed in 3.14.


#8

it works perfectly now i just had to disable the login animations and the freeze thing is gone


#9

For you other boys having problems while hovering the Play button: I deactivated EAX in the winecfg and it worked again for me

EDIT: Nope, still doesnt work and freezes


#10

OK, I was having some other issues with my PC that I would say were not directly LoL related.

I installed a wine library repository I found from doing some internet/forum searches. It fixed all my sound issues with my system and wine apparently arguing over resources. Now all my sound works as it should with wine and any other apps. It also installed some video libraries that installed Vulcan 1.0.49 and other tweeks.

I still have not turned my chat back on but everything else is working as it should most of the time. Every once and while my after battle screen will still hang up and I will have to kill and restart my LoL.

Just wanted to give an update to everyone


#11

Oh yeah, I am also using Linux Mint 18 Cinnamon


#13

Fixed by installing the latest version published just 2-3 days ago. It uses 64bit prefix instead of 32bit. Make sure to install the new prefix in a different location from the old one to avoid problems. After you can simply copy/move LOL directory from the old prefix to the new one, so you don’t have to update again.

This new version works really well. With the old 32bit version I had 6-40 fps (very unstable) and now it runs 40-50 fps.


#14

hi there.
i cant get this to work for my life.
been trying since it was published here after 8.15 patch. tried again today (full download, install, update) and nothing. it keeps crashing at start.
all i get is “game has quit” message and this error LeagueClient.exe(00000009): ALWAYS| Application Version:8.16.241.8451 - CL:2418451 - Build Date:Aug 11 2018 - Build Time:14:45:41

im on linux 4.14.60 manjaro 17.1.11 cinnamon 3.8.8 runner wine esync 3.13 x86_64

any help would be appreciated :wink:

thanks!


#15

How do I know that I’m using a 64 bits prefix? And how do I create one?


#16

working!!! not freezes !! on lol 3.13x i just had to change the launcher size!
everytime you enter!


#17

Right click > Configure > Game options > Prefix Architecture. If it’s 32bit then you need to backup your LoL directory delete the current prefix, install V8.15 and put back the lol folder. If you try to change to 64bit within the configuration panel it will fail, you can try if you want.


#18

So my freezing issue continued on and off at random. I have changed to wine version to 3.15 staging and it works just fine even with the voice chat on, atleast for me. I am running 64bit LinuxMint 18.3 Cinnamon