Back to the main site

League of legend on ubuntu 16 : can't switch to other programs during the game


#1

On a fresh ubuntu 16.04 install with actual lutris and actual lol lutris install, during the game, i can’t switch to others programs : when i hit alt+tab, the screen suddenly freeze on lol, without any animation. It’s not a computer freeze, because the sound stil play.
It’s not a graphic card problem, because i have another ssd where linux mint and lol with lutris are installed, and works perfectly.
I tried various changes about screen in lutris config, wine config, tried with lol configuered on windows, but in each case it don’t really works : the screen is not screen is not feeze anymore on lol, i can switch between programs, but when i come back in lol, there’s problems with mouse, and not full screen display of the game …


#2

I installed a fresh version of Lubuntu, which use LXDE desktop, instead of Unity for ubuntu, and then Latest lutris with LOL : no problem to switch between program during the game ! so i think it’s a Unity bug.


#3

get in game and go to settings and switch to either “windowed” or “borderless”. full screen has issues with alt tabbing. I prefer borderless


#4

In windowed, the camera don’t mouve with mouse, and some keys don’t works.
In borderless, sometimes no problem, but sometimes same problem as on windowed :frowning:

Edit : i think the only way to avoid this problem, is either install and use another desktop environment, or upgrade to Ubuntu 18, which use Gnome (but need to swap in it by log of, then change desktop to “ubuntu”, then log on).


#5

Right-Click game > Wine Configuration > Graphics > Automatically capture the mouse in full-screen windows.

That should capture your mouse in fullscreen windowed.

Keys not working is because your DE is eating the keys in Windows mode. You just have to look where they set it to something, and turn it off.


#6

“Automatically capture the mouse in full-screen windows.” : it was already checked …

“fullscreen windowed” : i think you mean windowed.

The mouse is well captured, because i can move character, but it’s buggy for moving the map.
It seems less buggy in bordeless …

Anyway, it works fine with Lubuntu, even in full screen.


#7

Honostly, Unity on 16.04 is dead tech anyways. I think it has something to do with compiz? Really don’t know.

Your suggestion to install a fresh 18.04 sounds the wisest to me.


#8

This is indeed a known issue with Compiz. Using a virtual desktop can be used a workaround or switching to another WM will fix the issue (this is the main reason why I switched to Gnome Shell a few years back).