League of Legend Login Server Not Responding

Hi Strider,

I just installed League on my wife’s machine with the latest lutris client. We are running antergos 64bit and previously I haven’t had any any issues on my other machine prior to 4.x releases. Anyways, when we finally got everything installed for her I am able to click launch and the login screen comes up, I then put in my credentials and after three attempts I get the errors listed in the screenshot. I also checked the league status page and of course nothing pertaining to authentication has any issue right now. Any ideas or is there any more information I can provide to help you debug the issue. I also checked the wine version running for this installer and it is staging-1.9.21-i386.

Screenshot: https://imagebin.ca/v/32dSp2HiqNbM

I am also in the process of re-installing the latest client on my own box that was previously running fine, since when I checked today and it wasn’t anymore and I keep getting bugsplats in the middle of the update process. Please let me know if there are any logs I can shoot you for that as well.

Thanks in advance for your help.

I also pulled the latest master from git and ran ./bin/lutris dv to use that launcher and had the exact same problem. I also have my original box to the same point as this now, since the updates finally applied and its doing the exact same thing on both machines so something appears awry unfortunately. @strider

I tested it… I’ve got no problem by running the LoL Client. No Problem in LoL or Lutris.

What distro are you running? Just curious if perhaps there is something else going on.

Yup just checked still a problem. Have you re-installed the client recently or perhaps you have had it installed for a while?

Okay so I solved the issue. When I when into the configure menu for League I changed the version of wine from staging-1.9.21-i386 to 1.9.2-staging-lol-i386 so I am betting if this was working for others they likely haven’t re-installed recently with the new version of wine for this installer. Sorry to be a pest but glad I figured this out in case others run into this issue.

Thanks @Cronyk for testing and @strider for making this awesome app in the first place.

One last question @Cronyk @strider I am still newer to this project / app and I had the older version of wine to try on my machine from previous versions but not on my wife’s. What is the process to install a different version of wine so that it will allow me to select it from the Configure menu of the game in the Lutris client? Apologies if this is a bit of a noob question but am honestly not sure.


So I’m also new but maybe I can help with this:

Go on the gears left top of Lutris to open runner menu, search for wine and click on “Manage Versions”, then search for your fitting version and check the checkbox left (This could take a while).

@Cronyk This worked perfectly as you described and I have since been able to resolve the issue. Thanks much.

1 Like

You’re welcome

Glad you managed to work this out. I’m surprised that you had to revert back to 1.9.2 since I had problems running the latest LoL update with it (also, wine doesn’t require a special patch to run Wine)

I had similar issues logging in the WoW servers and what did it for me was using WineHQ Staging (the one from Wine’s PPA)

@strider To clarify I had this version staging-1.9.21-i386 in use when re-installing and running the updates from the LOL client but once everything finally installed, yes I agree this was a bear and took multiple tries, I couldn’t login and switched over to the 1.9.2-staging-lol-i386 version. That said other versions may work but this combo caught me going from a total re-install to playing the game. If only Riot made this a bit easier on us :wink: .