KeyError: "store"

I restarted my computer this morning and tried to start up lutris and it wouldn’t start. running the debug command gives the following output.

Unable to load locale dir, translations won’t work.
2021-01-01 23:49:29,749: Your version of python-magic is too old.
2021-01-01 23:49:29,838: Initializing lutris
2021-01-01 23:49:30,818: Runtime up-to-date. Initialization complete.
INFO 2021-01-01 23:49:30,821 [application.do_command_line:314]:Lutris
INFO 2021-01-01 23:49:30,821 [startup.check_driver:57]:Running AMD Mesa driver 20.3.1 on Radeon RX 580 Series (POLARIS10, DRM 3.40.0, 5.10.2-2-MANJARO, LLVM 11.0.0) (0x67df)
INFO 2021-01-01 23:49:30,821 [startup.check_driver:69]:GPU: 1002:67DF 1458:22FC (amdgpu drivers)
Traceback (most recent call last):
File “/usr/lib/python3.9/site-packages/lutris/gui/”, line 214, in do_activate
self.window = LutrisWindow(application=self)
File “/usr/lib/python3.9/site-packages/lutris/gui/”, line 85, in init
File “/usr/lib/python3.9/site-packages/lutris/gui/”, line 301, in set_service
self.service = services.get_services()service_name
KeyError: ‘store’

I have to kill the program at this point because no matter how long i leave it for it will not move past this point. I’ve tried working through the source code to see if it might be something in there but reproducing the problem on my laptop yields no results