(itch.io) Lutris flatpak does not fetch the games in my library

Hi, I have an issue; when I log in with my Itch credentials, the Lutris flatpak does not show anything on my screen.

The output of ‘flatpak run net.Lutris.lutris -d’ is as follows (the space between https and : is because new users can’t post more than two links)

DEBUG 2024-05-06 14:13:01,901 [base.login:430]:Connecting to itch.io
DEBUG 2024-05-06 14:13:21,400 [base.wipe_game_cache:441]:Deleting itchio cache /home/redacted/.var/app/net.lutris.Lutris/cache/lutris/itchio/api/
DEBUG 2024-05-06 14:13:21,400 [base.wipe_game_cache:175]:Deleting games from service-games for itchio
DEBUG 2024-05-06 14:13:21,402 [http._request:88]:GET https ://api.itch.io/profile
DEBUG 2024-05-06 14:13:21,640 [http._request:88]:GET https ://api.itch.io/profile/owned-keys?page=1
DEBUG 2024-05-06 14:13:42,966 [http._request:88]:GET https ://api.itch.io/profile
DEBUG 2024-05-06 14:13:43,248 [base.wipe_game_cache:441]:Deleting itchio cache /home/redacted/.var/app/net.lutris.Lutris/cache/lutris/itchio/api/
DEBUG 2024-05-06 14:13:43,250 [base.wipe_game_cache:175]:Deleting games from service-games for itchio
DEBUG 2024-05-06 14:13:43,253 [http._request:88]:GET https ://api.itch.io/profile
DEBUG 2024-05-06 14:13:43,532 [http._request:88]:GET https ://api.itch.io/profile/owned-keys?page=1
DEBUG 2024-05-06 14:13:49,830 [http._request:88]:GET https ://api.itch.io/profile
DEBUG 2024-05-06 14:13:50,080 [base.wipe_game_cache:441]:Deleting itchio cache /home/redacted/.var/app/net.lutris.Lutris/cache/lutris/itchio/api/
DEBUG 2024-05-06 14:13:50,082 [base.wipe_game_cache:175]:Deleting games from service-games for itchio
DEBUG 2024-05-06 14:13:50,087 [http._request:88]:GET https ://api.itch.io/profile
DEBUG 2024-05-06 14:13:50,332 [http._request:88]:GET https ://api.itch.io/profile/owned-keys?page=1

I tried logging out and logging back in but Lutris still doesn’t show anything. It just says ‘No games found’

Do I have to do some extra steps on my Itch account or something? I also checked flatpak for updates and there are none for Lutris.

Hello, if your Flatpak does not show files on your filesystem, you need the flatpak flatseal, than search you Lutris flatpak in there an scroll down to the point filesystem and set it to on. thats often a problem that games can not be found, or save on other locations.
flatpak install flatseal

No, this is not it. I still tried allowing trough Flatseal the path ~/.config/itch/apps and ~/.config/itch.
It didn’t work, as in it didn’t detected the games that are already there.

But my original issue is that Lutris is not fetching my accounts catalog. I checked with Itch support and my games should appear because I paid for them (Itch won’t register free games to users accounts, only games purchased).

The log I pasted shows that Lutris does fetch the Itch api, but it just doesn’t show the games on the screen. But I can get my list of games from GOG, which uses the same process.

You missed off the version, but 5.17 adds itch titles without issues. I moved to the Git version partly because I wanted ULWGL for easy Proton support, but mainly because I had previous issues when refreshing/adding accounts with 5.16.

I know bleeding edge isn’t for everyone, but the .deb package for 5.17 is out now - might want to try that briefly so you know if the flatpak will work when it gets updated.

You missed off the version

Oh, sorry. Flatpak is version 0.5.17 (2024-04-12 00:45:15 +0000)

I’m on Arch so I gave the AUR version a shot (lutris-git 0.5.17.r1.ge8bfc73bb-1, last updated 2024-05-01 14:30) but I uninstalled it because that version has the same problem with Itch and GOG.

I could try the pacman version, but I don’t know, it’s release, 0.5.17-4, was pushed on the same date as lutris-git (2024-05-01)

As for connecting my GOG account using lutris-git, this is the log (once again I separated https from the url to escape the Lutris forum restriction)

DEBUG 2024-05-10 12:09:10,139 [http._request:88]:GET https ://embed.gog.com/userData.json
DEBUG 2024-05-10 12:09:10,880 [base.wipe_game_cache:465]:Deleting gog cache /home/redacted/.cache/lutris/gog-library.json
DEBUG 2024-05-10 12:09:10,880 [base.wipe_game_cache:176]:Deleting games from service-games for gog
DEBUG 2024-05-10 12:09:10,890 [http._request:88]:GET https ://embed.gog.com/userData.json
DEBUG 2024-05-10 12:09:11,595 [http._request:88]:GET https ://embed.gog.com/account/getFilteredProducts?mediaType=1&page=1
DEBUG 2024-05-10 12:09:12,520 [http._request:88]:GET https ://embed.gog.com/account/getFilteredProducts?mediaType=1&page=2
DEBUG 2024-05-10 12:09:13,427 [http._request:88]:GET https ://embed.gog.com/account/getFilteredProducts?mediaType=1&page=3
DEBUG 2024-05-10 12:09:15,224 [http._request:88]:POST https ://lutris.net/api/games/service/gog
DEBUG 2024-05-10 12:09:18,003 [http._request:88]:POST https ://lutris.net/api/games/service/gog?page=2

And just as with Itch, none of my purchases appear despite fetching the API seemingly without errors

Agree, I would at least expect to see an error if Python wasn’t doing something right.

I have bought maybe 5 games off Itch, but only one actually shows up as runnable, even though I saw icons for others sort-of-appear during the intial setup, but they are C64 cartridge images, so I wasn’t too fussed. GoG works fine though. Does your /home/user/.cache/lutris/gog-library.json actually contain anything after it does a refresh?
Sorry if this sounds basic, but just check you’re not displaying only installed games :slight_smile:

1 Like

just check you’re not displaying only installed games

Oh my god, they just appeared on screen. All of them, Itch and GOG. Why is that turned on? I don’t remember changing that?

Thanks for the help. I must look like a total schmuck.

1 Like