Issues with joypad

I have managed to get the joystick control panel working by… wait for it… creating a ‘Games’ directory in my home directory

Hi guys

I have tried to get my joypad working for some games - Vice City is an example and the axes on the joypad are wrong - the left stick will work horizontally but I can’t move vertically as this is controlled by the x axis on the right stick, weird huh? I tried to use the built in joystick control panel but get an error message of

Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 801, in __bootstrap_inner
File “/usr/lib/python2.7/site-packages/lutris/”, line 79, in run
self.game_process = self.execute_process(self.command, env)
File “/usr/lib/python2.7/site-packages/lutris/”, line 110, in execute_process
cwd=self.cwd, env=env)
File “/usr/lib/python2.7/”, line 710, in init
errread, errwrite)
File “/usr/lib/python2.7/”, line 1335, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory: ‘/home/martyn/Games’

Traceback (most recent call last):
File “/usr/lib/python2.7/site-packages/lutris/”, line 195, in watch_children
self.return_code = self.game_process.returncode
AttributeError: ‘NoneType’ object has no attribute ‘returncode’

Does anyone know how to fix this?

By the way, I am running Manjaro Xfce 64 bit, kernel 4.5.0-1 with a SpeedLink SL-6535-BK joypad. The same issue also occurs on other kernels.

Many thanks

ok, this is really strange now. I did a fresh install from an older CD and didn’t update the kernel. So the kernel is 4.1.19-1, I created a Games folder in my home directory, installed Lutris. Ran Lutris with lutris -d, ran the installer from GTA: Vice City (I just love that game) and first of all, had a problem with the mono installer (I’m assuming that’s what it is) because a window about 5px by 5px game up, I hit enter which seemed to work. Logged in with my Steam account and started the game - joypad works flawlessly. I am now going to try updating to a later kernel to see if that messes up my joypad. In the meantime, if anyone can explain what is going on, I’d be ever so grateful as I am stumped.

I have tried it with the 4.4.5-1 kernel, ran vice city and the joypad axes were messed up, I reverted to the older 4.1.19-1 kernel and as soon as I started the game, the joypad was perfect again. Does anyone know what is going on? I’m quite happy to stay on 4.1.19-1 but I don’t know how long before I will have to move to a newer one.

I’ll have to install Arch on my hard drive, I currently only have a VM. I know that I’ve tested GTA3 a few weeks ago and was able to play with a controller using xboxdrv, Vice City should behave similarly.

Here’s my xboxdrv config for GTA3 (used in the system options in the game configuration):

–trigger-as-button --ui-axismap x2=ABS_Z,y2=ABS_RZ --ui-buttonmap A=BTN_B,B=BTN_X,X=BTN_A,TR=BTN_THUMBL,TL=BTN_MODE,GUIDE=BTN_THUMBR