Back to the main site

Issues with games after change VGA

Hi there,

A few weeks ago I’ve changed my Radeon Rx580 to a Radeon Rx6800. I’m using Manjaro linux, and didn’t change anything else. Since then Bethesda version of Doom Eternal and The Division from Ubisoft ( Lutris dedicated install script ) are no longer started at all. The launcher starts, but the games are not. I don’t know what could be the problem, some help could be useful.

thanks in advance

regards

Laszlo

A few things I forgot to mention:
1 - Before card replacement both mesa and amd’s own opensource driver were installed. I don’t know, if it is affecting anything or not, but before I removed amdgpu driver, the above mentioned issue were present.
2 - With Rx580, the following things worked mostly without issues:

  • Steam games using Proton ( using 3rd party Proton builds as well )
  • Bethesda launcher with Doom Eternal ( lutris )
  • Epic Games launcher with several, but not all of the free games I get ( lutris )
  • Uplay with The Division ( lutris )
  • Battle.net with World Of Warcraft ( lutris )
  • GOG with Cyberpunk2077 ( lutris ) ( the game started, I was able to create my char, but after it freezes )
  • Origin with EAPlay SW Fallen Order ( lutris )

3 - With Rx6800:

  • Steam games using Proton ( using 3rd party Proton builds as well ) - Works well just like before
  • Bethesda launcher with Doom Eternal ( lutris ) - Launcher starts, game installs, game doesn’t start
  • Epic Games launcher with several, but not all of the free games I get ( lutris ) - Launcher starts, didn’t try to install and run anything for a while
  • Uplay with The Division ( lutris ) - Launcher starts, game installs, game doesn’t start
  • Battle.net with World Of Warcraft ( lutris ) - Works well just like before
  • GOG with Cyberpunk2077 ( lutris ) - Launcher starts, game installs, game doesn’t start
  • Origin with EAPlay SW Fallen Order ( lutris ) - Didn’t try it for a while, hence it was the less stable before as well

Update:

Bethesda launcher with Doom Eternal now works fine. Solution was:

  • Wine version : lutris-6.0-x86_64
  • DXVK version : 1.7.1L

Epic Games launcher:
Installed a few games I previously played with, they are just working fine.

GOG with CP2077: thanks to Axle_Grease

  • Wine version : lutris-6.0-x86_64
  • DXVK version : 1.7.3L-03f11ba
  • Fsync enabled

Origin:
I didn’t try it itself, however from Steam it is working fine with It Takes Two. Plan to subscribe EA Play through Steam and try the available games

UPDATE!!!
Uplay :

  • Wine version : lutris-6.0-x86_64
  • DXVK version : 1.7.1L

Seems to working fine for now