Back to the main site

Issues with C&C3: Tiberium Wars [Origin]

I’m trying to play Command & Conquer 3: Tiberium Wars and I’m experiencing several issues that I’d appreciate some help with.

  1. When starting up, Origin often uses the entire CPU and freezes the whole system until I either kill Origin from the terminal or it crashes on its own. There seems to be a pattern: the issue doesn’t occur the first time I start Origin after booting the OS, but it occurs almost every subsequent time. Here’s a log of this happening: https://paste.ubuntu.com/p/hZMn6h9vzy/

  2. When Origin successfully initializes, and I start TIberium Wars, the sound immediately becomes distorted, as if Pulseaudio suddenly dropped to a lower bitrate.

  3. In game, shadows are not rendered correctly. Instead of looking smooth, they look blocky/jagged. See screenshot.

  4. Turning anti-aliasing to max kills performance and brings it down to 2-3 fps, where it runs flawlessly on Windows on the same machine and the same settings.

I see json files can’t be uploaded here, so where should I upload the json file created by the lutris --submit-issue command?

Update.

  1. When starting Origin freezes the system, I’ve noticed that it’s not always the Origin process that uses the entire CPU, sometimes it’s journald, and it continues even after I kill Origin.

  2. Not exactly a solution, but I tried running JACK with the Pulseaudio sink, and now when I start the game, the sound no longer becomes distorted.

I tried running the game with DXVK turned off, which I’ve found helps with issues 3 and 4. With DXVK turned off, the game increases the maximum anti-aliasing from 4 to 5. Setting AA to the new maximum kills performance just like before, but with a setting of 4 the framerate is significantly improved. The appearance of the shadows is improved as well (due to higher AA?).

Update.

After further testing, I’ve found that all Wine versions from lutris-5.7-11 and up cause the system to freeze when Origin starts. With previous versions of Wine, Origin runs just fine, but unfortunately, none of those versions allow me to play Tiberium Wars with DXVK turned off because the game gets stuck on the EA intro screen.

Update.

None of the Wine versions available in Lutris freeze my system if they’re run in the virtual desktop, including lutris-5.7-11 and up. And this way, I’m able to play the game with DXVK turned off in most versions of Wine, though performance is inconsistent; sometimes performance is great with AA turned up to 4, but other times my framerate turns into a slideshow, and I have dial down the AA.