Issue with RUNNING Need for Speed Most Wanted Black Edition [Fixed... I think]

Hi, so I was trying to install the game. I’m using the files from MyAbandonware and the installer for the Black Edition. When the installation process started, I got this line:

/usr/bin/chmod: cannot access ‘/home/todor/.cache/lutris/installer/need-for-speed-most-wanted/install’: No such file or directory

And then the installer stops. What’s happening? Please help!

Edit: Solved. The solution turns out to have been much simpler than I thought it would be. I created an empty folder called “install” in the place it was missing and that was that. Honestly kind of pissed how stupid simple a solution this is but anyways.

Edit 2: After resolving the original issue, i.e. installing the game, I then tried running it and it refuses. Here’s the crash log:

Started initial process 24066 from /home/todor/.local/share/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine /home/todor/Games/need-for-speed-most-wanted/drive_c/Program Files/EA GAMES/Need for Speed Most Wanted/speed.exe
Start monitoring process.
fsync: up and running.
wine: Unhandled exception 0xc0000090 in thread 110 at address F700CD60 (thread 0110), starting debugger…
Unhandled exception: invalid float operation in 32-bit code (0xf700cd62).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:f700cd62 ESP:00b64e30 EBP:00000000 EFLAGS:00010247( R- – I Z- -P-C)
EAX:00000000 EBX:f75bd000 ECX:ecb65a40 EDX:00000600
ESI:00000000 EDI:00b64e7c
Stack dump:
0x00b64e30: ecbb02c8 ecb66f40 00000002 00b64f0c
0x00b64e40: efba9d00 ecb8ffd0 ffffffff 7fefffff
0x00b64e50: ffffffff 7fefffff f75a7600 00000000
0x00b64e60: ecb69500 00b64e7d 02720672 f7c97917
0x00b64e70: 00b650bc 00000284 f7e2a000 03020100
0x00b64e80: 07060504 0b0a0908 0f0e0d0c 8f172a00
=>0 0xf700cd62 (0x00000000)
0xf700cd62: fxch %st(3)
Module Address Debug info Name (39 modules)
PE 00120000-00184000 Deferred dsound
PE 00400000-00a78e4e Deferred speed
PE 010b0000-012fa000 Deferred d3dx9_26
PE 01300000-01c5f000 Deferred shell32
PE 01c60000-01d27000 Deferred winmm
PE 61500000-6152f000 Deferred iphlpapi
PE 61740000-61783000 Deferred advapi32
PE 62440000-62769000 Deferred d3d9
PE 62fc0000-6304d000 Deferred rpcrt4
PE 63480000-6348c000 Deferred version
PE 63bc0000-63bda000 Deferred shcore
PE 64a40000-64a94000 Deferred shlwapi
PE 666c0000-666cf000 Deferred hid
PE 66b00000-66b3e000 Deferred win32u
PE 682c0000-682eb000 Deferred winevulkan
PE 68500000-6855b000 Deferred combase
PE 688c0000-688ea000 Deferred netapi32
PE 68e00000-68e11000 Deferred aclui
PE 69540000-6958f000 Deferred dinput8
PE 69ac0000-69acd000 Deferred vulkan-1
PE 6a040000-6a062000 Deferred msacm32
PE 6a280000-6a32c000 Deferred msvcrt
PE 6a400000-6a534000 Deferred ole32
PE 6afc0000-6afd6000 Deferred tapi32
PE 6bc00000-6bc2c000 Deferred sechost
PE 6bcc0000-6bd41000 Deferred setupapi
PE 6c9c0000-6ca46000 Deferred gdi32
PE 6cc40000-6cd9c000 Deferred comctl32
PE 6d300000-6d308000 Deferred shfolder
PE 6d780000-6d7a8000 Deferred ws2_32
PE 6e4c0000-6e4d6000 Deferred dnsapi
PE 6ed00000-6ef40000 Deferred user32
PE 6f480000-6f48b000 Deferred nsi
PE 70b40000-70c18000 Deferred ucrtbase
PE 71200000-7121c000 Deferred imm32
PE 7b000000-7b0ec000 Deferred kernelbase
PE 7b600000-7b81e000 Deferred kernel32
PE 7bc00000-7bcab000 Deferred ntdll
PE 7e460000-7e464000 Deferred winex11
process tid prio (all id:s are in hex)
00000020 start.exe
[“C:\windows\system32\start.exe” /exec “/home/todor/Games/need-for-speed-most-wanted/drive_c/Program Files/EA GAMES/Need for Speed Most Wanted/speed.exe”]
00000024 0
00000038 services.exe
0000003c 0
00000040 0
0000004c 0
00000050 0
0000005c 0
00000070 0
0000007c 0
0000008c 0
0000009c 0
000000b4 0
000000e8 0
00000044 winedevice.exe
00000048 0
00000054 0
00000058 0
00000060 0
00000064 0
000000c0 0
00000068 winedevice.exe
0000006c 0
00000074 0
00000078 0
00000080 0
00000084 0
00000088 0
00000090 0
00000094 plugplay.exe
00000098 0
000000a0 0
000000a4 0
000000a8 0
000000ac svchost.exe
[C:\windows\system32\svchost.exe -k LocalServiceNetworkRestricted]
000000b0 0
000000b8 0
000000bc 0
000000c4 tabtip.exe
000000c8 0
00000104 0
00000108 0
000000cc explorer.exe
[C:\windows\system32\explorer.exe /desktop]
000000d0 0
000000d4 0
000000d8 0
000000e0 rpcss.exe
000000e4 0
000000ec 0
000000f0 0
000000f4 0
000000f8 0
000000fc 0
00000100 0
0000010c (D) C:\Program Files\EA GAMES\Need for Speed Most Wanted\speed.exe
[“C:\Program Files\EA GAMES\Need for Speed Most Wanted\speed.exe” ]
00000110 0 <==
00000114 2
00000118 1
00000124 0
System information:
Wine build: wine-7.2-1-g1f8837bdccd (Staging)
Platform: i386
Version: Windows 10
Host system: Linux
Host version: 6.0.12-76060006-generic
Monitored process exited.
Initial process has exited (return code: 36864)
Exit with return code 36864

According to it, there’s some variable in the executable that’s fucked up. Or at least that’s what I’ve been able to parse. I don’t know jack about coding.

Edit 3: Just tried running the game randomly and… it works? I have no idea why. I had restarted my computer a couple of times before now. Was that what fixed it? I genuinely have no fucking clue. Whatever, problem solved, I guess.

1 Like