Issue with and starcraft ii

So no matter which version of wine I try (wine-ge, default wine from the install script or wine staging), the “stop” command doesnt stop the background processes. They remain until I log off or sometimes I have to restart completely. I am using popos 22.04. I have been googling the fuck out of this issue and tried wine kill scripts and commands it it just isnt working correctly. Something is definitely wrong with either Lutris or Wine and I am not sure which. But stop command doesnt work, wineserver kill commands dont work. I can close the tasks manually in HTOP/etc. But this is annoying since there is like 10-20+ processes not to mention agent.exe, battlenet.exe, winedevice.exe and others. Its truly annoying cause every time i do a google search and look for a solution that “works” it simply doesnt work. I have tried disabling fsync/etc. I also find it annoying that it takes multiple launches for sc2( to launch. I have multiple computers and multiple installs with the same issues. I even tried a vanilla install of popos 22.04 and fresh lutris and it still has stuff running after stopping and still fails to launch sometimes. Anyone have any NEW information on this issue? It used to work perfectly last year. Not sure where it all went poof.

1 Like

On the runner options tab, try disabling esync and fsync.

Like I’ve said previously it does not work. I tried it again and pressed stop after restarting and running lutris with both options disabled and a shit load of tasks are still there.

there are 2 options that I use.

  1. change the executable to point to the sc2 game executable (I point mine to Wow.exe) and only switch back to when you need to do an upgrade.
  2. Install in Steam using this link and in launcher, locate your existing installation of the game.
    Both are non-ideal work-arounds but at least Steam kills everything when crashes and you press the stop button (no agent or processes, winedevice or wineserver left hanging around). I don’t know what changed, whether it was a update or something else, but last year this ran without issue and now it is a pain in the !#@$% with the orphan processes and wineserver core dumps on launch. I have gone back to 5.x runners (which limit me to dx11 yuck), tried bottles, flatpak and steam. All have the same wineserver coredump issues with the current installations.

Thank you so much fro the tips I will try them out and let you know how they work out.


option 2 is working great. I can see how the first option would be useful as well since you wont be running all that blizzard garbage in background but so far i really like option 2 and i dont have to restart my machine anymore. Thanks man!

No problem.