Back to the main site

Issue launching games


#1

Hi Lutris users,

I have an issue since few weeks and I can’t find how to fix it.

My library on Lutris is :
Guild Wars 2
LoL
Dwarf
Hearthstone

Whenever I launch a game on Lutris, my user’s session is disconnected. I don’t know why. I’ve tried to to change Wine version using but It keep crashing.

Here is my config :

OS : Linux Mint 19
Kernel : 5.0.0-050000-generic

Any ideas how I can fix it ?

Thanks

EDIT: i tried to gather some infos with debugger but since my session is disconnected everytime i loose everything. All logs files for games are empty

lutris --submit-issue
2019-04-14 09:08:40,038: Running Lutris 0.5.2.1
2019-04-14 09:08:40,039: Using X.Org
2019-04-14 09:08:40,039: Running Mesa driver 19.0.1 on Radeon RX 580 Series (POLARIS10, DRM 3.27.0, 5.0.0-050000-generic, LLVM 8.0.0) (0x67df)
2019-04-14 09:08:40,039: GPU: 1002:67DF 1458:22FC using amdgpu drivers
2019-04-14 09:08:40,039: GPU: 8086:0412 1458:D000 using i915 drivers
INTEL-MESA: warning: Haswell Vulkan support is incomplete
2019-04-14 09:08:40,062: Vulkan is supported
2019-04-14 09:08:40,062: Updating DXVK versions
TypeError: on_destroy() takes from 1 to 2 positional arguments but 3 were given


#2

This should be fixed in the upcoming release 0.5.3. In the meantime you can use the latest git version:

git clone https://github.com/lutris/lutris.git

cd lutris

./bin/lutris