IsDone.dll cant install games

Hi, I tried to change the default install location for games in Lutris to another drive as the drive my OS is on was getting full, after changing the game install path and also wine prefix location I was unable to get a game to install any where other than the default location /home/.wine I changed everything back to the way is was, freed up some space and tried to install a game, which failed with an error about IsDone.dll, I had 23GB free at the time and the game needed 2GB. I uninstalled lutris and wine and renamed the .wine folder to .wine.old and renamed all remaining Lutris folders. I reinstalled wine and Lutris, I ran into the same issue with IsDone.dll. I remove lutris and wine again deleted the new folders that were created and changed .old back to what they were. I then installed wine and lutris again. My games installed piror to this issue are running fine. I installed a new game and this time used the default system\wine runner and the game installed, I then uninstalled the game and then tried with the lutris runners and ran into the IsDone.dll message again. I tried downloading a few more lutris runners and had the same problem. If I install with system\wine runner then change runner to lutris after install the game will hang or crash. The game will run fine with system\wine runner. Ive spend a few hours on this so far and was thinking about reinstalling my OS, any help you give me would be gratefully appreciated.

1 Like

Highly unlikely reinstalling your OS will do anything, nor installing other runners. Generally when you change the install location for games, you don’t touch your wine prefix location. I have games installed across 3 drives without issues. Which game is giving the issue, Katana Zero or Warhammer?
You might want to check your hardware too - there are a lot of memory allocation errors in the log.

Its all games I’ve tried installing since I tried changing the location, games installed previous to that still work fine. Its strange that if I use the default system runner I can install and run new games. I checked my hardware with memtest86 and ran prime95 and had no issues. Everything else in Pop OS is fine and also in windows.

Might seem strange, but rather than change the default location for all games in the Lutris options, simple change the location when prompted installing a new game.
Next download the Wine-6,20-GE-1 and extract it into a directory you can easily find. With Warframe, in the runner configuration select custom, and in the path navigate to the directories where you extracted the Wine-6.20-GE-1 version and locate wine in the bin directory. Now if Warframe successfully runs (probably will want to install mono or some other files), then see if you can run the Epic Games installer and select an installation directory on your preferred disk. Epic Games installer is relatively small to install and doesn’t take long to download.

That half worked, I cant install using Wine-6,20-GE-1, I still run into the issue with isDone.dll, I can install using the default system runner, but game now runs when I switch runner back to Wine-6,20-GE-1 when before any new installs would crash when ran with anything other than the default system runner. Thanks for your help.

When you say “install Wine-6.20-GE-1”, can you not extract the archive into a directory? Does you runner options look like this?

Or did you Extract it to /home/USERNAME/.local/share/lutris/runners/wine/

I extracted wine-6,20-GE-1, into /home/USERNAME/.local/share/lutris/runners/wine/
I also tried it as you suggested and had it in a folder in my downloads called runners and pointed lutris towards wine64 When I was unable to install a game using it as you asked I then extracted to the default lutris folder. Both ways still gave me the isdone.dll error.

Did you get the isdone.dll error installing Epic Games Store? Also what is your hardware config (cpu, amount of ram and cpu)? isDone.dll errors seem common with many Windows games installation so it is not a Linux issue and in some cases is related to insufficient temp space or ram (pagefile size in Windows) or using a corrupt install image (downloaded image when game required a CD for installation).
Also, can you get a screenshot of the exact isdone.dll error you are seeing and which game you are trying to install that gives this error? Do you see the same error in Windows?

I did get the error installing epic games store. Ive tested 10 games so far and all fail to install with isdone.dll if using anything other than the default system runner. The games install fine under windows and using the default system runner in Linux its just any of the other runners that cause the issue when trying to install. The below error I got when trying to install Starbound with Lutris-ge-6.20-1
CPU: 5800x
GPU: RTX 2080

Lutris game install error

LOL - 2 of 3 in the one error!!!

Anyway, seems your issue has been raised in another form on the Lutris github to allow different runners to be used for the installer rather than the current default Lutris runner. Seems this did create some issues for installers that require specific elements not provided by the base runner.
Mostly, once you have set your default Wine prefix, there is little need to move it. Modify, yes, you may need to use the WIne Configuration option for a game in Lutris to set Windows 10 if you wish to use a dx12 game. Some games require dotnet 4.5 or 4.8 to added to the prefix which the installer may not do. For running the game, use the Wine Version in Runner Options to select one which is recommended for your game.
If you keep it simple, it mostly works. In the meantime, use the method nearly every Lutris user uses - install with the default runner, configure your runtime options and runner in the game configuration and enjoy when it works, post here when it doesn’t…

1 Like

Thanks for your help Jhu, I learned a little bit along the way.