Back to the main site

Is there anyone who know how WINE Virtual Desktop and non Virtual Desktop works

The Latest Lutris (0.5.9.1) got D3D Extras v2 and DXVK NVAPI v0.5, so with WINE version lutris-fshack-6.21-6 with DXVK v1.9.2, VKD3D v2.5 and esync, fsync enabled I got Far Cry 6 running in my modest Ryzen 2600 with Radeon RX560 4GB with 16GB RAM.
In my trial by error I noticed that the game freezes during “Warming up PSO cache” when is NOT on Virtual Desktop mode.
So… for more immersive experience I wish I could run in fullscreen at my playable resolution which is 1280x720 as rx560 is already “outdated” for actual standards when Virtual Desktop adjusts itself in a window 1280x720.

As I had a little experience in programing but not low level like that, so I was wondering if this is not a WINE bug when passing buffers to the application something like pre-allocation being too small that game freezes or giving some random numbers misleading the pointer in the memory.

If someone knows how to make wine goes to something like “fit to monitor’s resolution” in virtual desktop please tell me.

Thanks in advance.

Are you installing it from origin or steam since they use a different prefix?

Try using system (Version) or WineHQ (Version) instead, depending on what you have installed i always recommend installing WineHQ, and if you want 7.X, you need the Dev versions. You can also try installing Proton-Wine, but i have never used that one.

And another thing i noticed with FC if you have Nvidia, is it has a problem with Some versions of the Driver, so you may have to roll back and try older versions.

The only FC game i don’t own is FC6 since I’m waiting on it to be 75% off on steam or origin before i get it, so i can’t even test it out.

Also, make sure you have the newest version of Wine.

1 Like

Well, it seems that on Wine 7.0 rc1 crashes instantly over uplay / ubisoft connect.

I also tried gamescope - former steam compositor - no success ;

About Wine versions, being in a Arch Linux environment I found some weeks ago an app called ProtonUp that gives me more easier way to install other wine versions for Steam and Lutris, so I’ve been trying others too and even compiled vkd3d from HansKristian github, then after Lutris latest update with D3D Extras v2 and DXVK NVAPI 0.5 the game runs with almost no workaround like HansKristian vkd3d.

My actual problem is my mixed PC, 4k monitor, low end graphics (which I wanted to upgrade but the damn pandemic and scalpers took away my chance), so I can run some high end games in below 1080p with medium settings but the first run most games always starts as 4k running like 3 fps, after changing some settings is totally playable.

I can mention that also FC6 got some updates that made the in game text appear.

Well, after another trial I found a workaround:
At this moment the game for some unknown reason freezes at “Warm Up the PSO cache” when doesn’t run in Virtual Desktop mode, but running in Virtual Desktop mode the window will resize according its resolution; Then I found that the game can run in a “Borderless window” inside its options, so I changed Lutris to use Virtual Desktop with my default resolution (3840x2160) ran the game and changed to Borderless Window in game settings which stretched to wine desktop resolution.

BTW I’m still thinking that WINE with virtual desktop and non virtual desktop may have totally different mechanics and when uses non virtual desktop may give a lots of null values crashing some apps sensitive to this condition, but it’s a guess

Another thing, I bought from Epic and I wonder why many companies are building their launchers, they are doing terrible jobs, It’s a mess to run “X” launcher which invokes “Y” launcher to run “Z” launcher so the game starts, some government must pass a law to prohibits this messy things, a website for buying it’s enough. At least it was possible to cut Epic launcher and run Ubisoft Connect which is also an unnecessary app to run the game.

Sorry my rant
And thanks for your reply

I don’t run in 4K, so I don’t know about that. I’m still on 1080P because a smooth experience when playing games is more important than high Pixels for me. Also, I see people on Arch Linux environment have more problems than on Debian when it comes to wine. I use pop!_os myself and have been on Ubuntu for many years before that all the way back to 14.xx

I just bought FC6 because Fuck it. I have the money, and I’m tired of playing Divinity 2.

So let’s see how well it runs.

PS you can check out my gaming on Linux here.
https://www.youtube.com/c/TheCasualGamers2020

Well, It’s not that I’m running games in 4K but when I have some work to do 4K gives me more room to work on it :grin:

So many people have this misconception about Arch Linux, it’s not Arch’s fault, Arch is more developer wise than Debian and derivatives and even Steam got the idea behind it they got their handheld gaming platform based on Arch, probably will be something like Manjaro, using some portion of upstream work and update after testing, when in Arch way I’m the tester.

Anyway, I have been using Linux since 1996 when I had first experience with RedHat since that I was going back and forth between Windows and Linux.
Windows Millennium and Vista killed my respect for Microsoft twice and the last version of Windows I had in my PC was Windows 7, along these years I had Debian, Ubuntu, openSUSE, Fedora, Manjaro, Antergos and others just to taste what is different but it’s like “Juan Cortez” says in the FC6, “Always use the right Tool for the Job.”, in my case Arch is mine :rofl:

So, have fun, this game is very funny and I loving it
Nice frag!

Same, just with Ubuntu. I don’t know the age i first tried Linux. All I can remember is it was free, and you got it sent on a disk. It came in an orange holder and was all commando based, no GUI; it has to be the late 90’s or early 00’s and I’ve been on and off Linux ever since. I started first really at using Linux back when Ubuntu 14 came out and used it for idk about 1/2 month, then off and then on again when 15 came out, and so on. I have only used POP!_OS for about two months now. I’m not going to play the game because Ubisoft is fucking with me. i got the “This product cannot be activated right now, please try again later” both on windows and Linux, so I’m kinda at a standstill.

For me I got in 3 and 1/2 inches diskettes then after with the advent of CDs I got CD versions too, my nightmare was to create a reasonable xorg.conf file for my 486 DX2 and after that the Pentium 233 MMX, video cards support was horrible at that time not mentioning CRTs monitors, Ubuntu and Mint saved me a lot when they arrived but my longest journey was with openSUSE I think something around 10 years.

But about the game, I had that issue twice too, IIRC after some Uplay / Ubisoft Connect update I got same error, restarting the computer doesn’t solve the problem?
For me some wine process got stuck I killed all but some variable may stood on memory probably tricking RNGs making the ubisoft app consider fake like wrong timestamps which renders wrong encryptions, I guess.
If doesn’t, I know that is PITA download 50+GB, delete everything reinstall it as I don’t know where Ubisoft stores login and keys like VDF file from Steam, removing and regenerating may fix some mismatch.

1 Like

i got it startr

After some trying, i got it working on windows. i think what did it was making sure Ubisoft connect was unstalled, resetting the DNS, and ensuring the old Cashe was deleted. Restart and install Ubisoft connect and the game, then it starts downloading the Cashe, and the game starts.

Now i just need to make it work on linux.