Is there any solution to the error in League of legends?

Running gamemoderun /home/mx/.local/share/lutris/runners/wine/lutris-lol-5.5-2-x86_64/bin/wine /home/mx/Games/league-of-legends/drive_c/Riot Games/League of Legends/LeagueClient.exe --locale=en_US
Initial process has started with pid 28992
Start monitoring process.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
fsync: up and running.
user.reg:671: Malformed value ‘“HDA Intel PCH HDMI/DP,pc”=3 (js)"=“disabled”’
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
000000.079| OKAY| Running from cwd ‘C:\Riot Games\League of Legends’.
000000.079| ALWAYS| Application Version:10.24.345.8390 - CL:3458390 - Build Date:Nov 20 2020 - Build Time:12:43:29
000000.080| OKAY| Initial working directory: “C:\Riot Games\League of Legends”
000000.080| OKAY| Current process: “C:\Riot Games\League of Legends\LeagueClient.exe”
000000.080| OKAY| Command line arguments:
–locale=en_US
000000.257| OKAY| Enabling Data API Dradis collection with endpoint: https://ekg.riotgames.com/messages
000000.276| ALWAYS| The following message is prepared to be sent to dradis:
Event Name: riot__rclient__event
common.os_platform: Windows
common.application_name: LeagueClient
common.application_version: 10.24.345.8390
common.cef_version: 74.1.19+gb62bacf+chromium-74.0.3729.157
common.installation_id: m+ca0A==
common.locale: en_US
common.os_version_major: 10
common.machine_id: TBjK+xsOLk6/NUr6w5vHCw==
common.os_edition: Ultimate N, x86
common.os_version_minor:
common.region: TR
common.session_id: 8dc397ae-07bb-be4a-961a-902f4e50e7fa
event_name: startup
crash_reporter: crashpad
000000.276| ALWAYS| Queued Dradis event to be sent.
000000.276| ALWAYS| Direct Launch enabled for league_of_legends.live in environment ‘live’ for app path ‘C:\Riot Games\League of Legends\LeagueClient.exe’ and install dir ‘C:\Riot Games\League of Legends’
000000.301| ALWAYS| Found associated Riot Client install (c:/Riot Games/Riot Client/RiotClientServices.exe)
000001.795| OKAY| Launched Riot Client with process 64
000001.795| ALWAYS| Riot Client started. Exiting with the expectation of being restarted (ExitForDirectLaunch).
000008.928| OKAY| EventCollector: 0 events remaining after thread join
000008.928| OKAY| Shut down EventCollector in 3665 milliseconds
Initial process has exited (return code: 0)
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object ‘libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

I am using mx linux. I want a better gaming experience. I could not find the solution for the errors. Is there anyone have an idea?

1 Like

hello Abraham, lol works on Linux, please first reinstall lol with Lutris script from this page that was recently updated:


If it still doesn’t work for you, verify you installed all needed wine dependencies:

Any chance you found solution?
After today’s update of lutris and other components, I got the same problem with lol