Back to the main site

Installed runners don't work


#1

Hi there,
I tried to install some runners, namely ZDOOM and Libretro. However, the games don’t launch.
Also, application menu shortcuts aren’t created either.
Lutris thinks they are, as the context menu entry now says “Delete application menu shortcut”, but they don’t show up.

I tried launching zdoom manually in terminal to see what’s the problem, but I only get:

./zdoom: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory

According to dnf, libjpeg is installed and up to date.
I’m using Fedora 27 Workstation (Gnome).

I don’t find any option to uninstall runners either, to try reinstalling it or installing them manually.


#2

Not sure about your libjpeg error but in order to remove runners it is relatively simple. Just click the lutris menu > Manage Runners. At the bottom of the window that opens is an “Open Runners Folder”. Then it is just a matter of selecting the runner folder you want to remove and deleting it.

As far as I am aware all runners come in their own prefix bottle, so deleting said folder will remove the runner completely allowing you to reinstall.


#3

Oh right. Guess I was still too preoccupied in my mind with coming from Windows, that I did not consider that option.

Still not much luck tho.
To figure out if any runners at all - if installed directly via Lutris - do work, I tested Mednafen. Specifically Pokémon Red/Blue and Crystal. Everything installed via the scripts on this website. Curiously, Red and Blue do work. Crystal does not.

So now the runner seems to work, but only with classic GB games.
With Crystal, the program just doesn’t start at all, just as with ZDOOM and libretro.
It says “Game is running” on the button for a moment, just to switch immediately to “Game has quit”.

Regarding the icons, I realized they do indeed show up after (quite) awhile. But only for some the icons actually appear. Heretic has the proper icon, all of the Pokémons do not.