Install of Ultima Underworld 2 SOLVED

Dear Forum,
I hope I’m in the right place, if not, feel free to delete my request. I’ve tried to install the GOG version of Ultima Underworld 2 using the Lutris installer script at I’ve confirmed that my GOG installer is the same as the one tested with this relatively current script.
After downloading the innoextract tool, the installer fails with the message:

Unable to find executable /home/sourpuz/.cache/lutris/installer/ultima-underworld-ii-labyrinth-of-worlds/innoextract

I’m running Fedora Workstation 35, using Xorg at the moment.
Does anybody have an idea what the issue might be?

Thanks in advance!

Try setting another folder as the cache folder, it might be a permission issue.

Hmmm, would I have to modify the installer to do this?

No, usually when it is asking you to confirm the files to download on the lower left corner there is a button that says cache. Click on it and write another folder.

I also checked the install script it might be that the extraction is not working for some reason.

Well, that worked better, but then the installer crashed :frowning:

Here’s the crash report:

lutris-wrapper: Ultima Underworld II: Labyrinth of Worlds
Started initial process 11166 from /home/sourpuz/.local/share/lutris/runners/dosbox/bin/dosbox -conf /home/sourpuz/Games/ultima-underworld-ii-labyrinth-of-worlds/DOSBOX/dosboxULTIMA2_single.conf -conf /home/sourpuz/Games/ultima-underworld-ii-labyrinth-of-worlds/DOSBOX/dosboxULTIMA2.conf -scaler normal2x -exit
Start monitoring process.
/home/sourpuz/.local/share/lutris/runners/dosbox/bin/dosbox: error while loading shared libraries: cannot open shared object file: No such file or directory
Monitored process exited.
Initial process has exited (return code: 32512)
All processes have quit
Exit with return code 32512

Now it has to do with a library, check that you have the required libraries for dosbox.

Yes, it seems libopusfile0 is missing, googling showed that this happens with some games in DosBox and can be remedied by installing libopusfile0. Problem is, the Fedora repos don’t seem to have it.

EDIT: Found it! It’s part of DosBox-staging which I had to install separaetly, noe it works! Thank you!

1 Like