Back to the main site

Include libgnutls30 (3.5.18-1ubuntu1) (32bit) in Lutris runtime


#1

Ubuntu 18.10 ships with libgnutls30 version 3.6.4-2ubuntu1 which seems to broken(?). When installing osu, it displays that it cannot connect to the internet and the console displays a message “gnutls: a packet with illegal or unsupported version was received”. When I ran the osu installer in Ubuntu 18.04 it worked normally.

Ubuntu 18.04 includes an older version of libgnutls30 (3.5.18-1ubuntu1)
Copying libgnutls.so.30 and libgnutls.so.30.14.10 from Ubuntu 18.04 installation to Ubuntu 18.10, putting it in ~/.local/share/lutris/runtime/lib32 and unchecking “Prefer system libraries” in Lutris Osu System settings fixed the problem and osu normally connected to the internet, installed and launched.

I don’t know if this is an ideal workaround, but it worked so I am suggesting it here. Ideally, GnuTLS or the osu servers should get fixed (if they are actually broken, I am just assuming that one of them is) but my hacky method worked and should also work for others.

And just to be clear, osu needs the 32 bit libraries.
Also, just installing the 32 bit version of libgnutls30 in Ubuntu 18.10 did not help (this fix is suggested by WineHQ on the osu page). The problem seems to be with the newer version of libgnutls that Ubuntu 18.10 ships with, not just with the fact that Ubuntu 18.10 does not ship with 32 bit libgnutls by default. Installing libgnutls30:i386 (3.6.4-2ubuntu1) does not help, the same error is still present.

Hopefully I made it clear what is (or was) the problem, how I fixed it and why I think the libgnutls library should be included in the Lutris runtime. If something is unclear, just tell me and I will try to clarify it.

Slight update (regarding osu specifically)

When playing osu and unticking “Prefer system libraries” the game can update normally (because of my workaround) but it breaks any internal (in game) links in the game that are supposed to open in an internet browser.