I'm using Lutris to play CyberPunk 2077 which is stored on a hard drive but I'm getting extreme amounts of lag and low frames consistently getting 10 frames a second

Pretty long header but Literally what the title says. The PC I was using should be able to play CyberPunk 2077 with ease but it doesn’t do so. I tried making sure that I didn’t accidently limit the game to only using a few cores instead of all of them but that wasn’t the case either. I’m not sure if it’s because the game is installed on a hard drive or what but I consistently get 10 frames per second too. It’s not like I’m getting sudden lag spikes or stuttering or anything. Since it is consistently 10 frames per second, could it be that I accidently limited the game to 10 frames per second somehow? My specs are an Ryzen 5800x CPU and an AMD RX 6700xt GPU with close to 20 GBs of ram. I’m pretty sure that should be able to run CyberPunk 2077 but it doesn’t.

As a side note, I haven’t actually started a save file yet after opening the game, The lag is happening even before I start playing so I’ve only seen the menu lagging so far since I didn’t get into a game. I ran a benchmark that was in the menu in the options which is where is it showed me some message that said something like “it seems like there are no P50s”?? maybe.

1 Like

Ill just assume you are using a Linux kernel released (and generally some sort of fairly up to date Linux version) sometime after your CPU/GPU were released (i.e. from about mid-2021 or newer since your CPU is from about Nov 2020 and your GPU is from about Mar 2021 (you can check current kernel using ‘uname -r’ in terminal))…

it’s almost like your GPU is not even active on the game as 10fps is horrible, especially considering how good your CPU/GPU is. so just to check some stuff (it’s recommended by Lutris team to install the newest Wine from official Wine website (winehq.org), so ill just assume you already did this)…

1)Use a GloriousEggroll runner for Lutris and make sure it’s active/selected in Lutris (Lutris v0.5.13 is the newest from May 2023). say ‘lutris-GE-Proton8-14’ (from main Lutris menu… ‘Runners > Wine’ and click on ‘folder’ icon which will bring up ‘Manage Wine versions’ and click ‘Install’ on it and make sure its selected on the CyberPunk shortcut you made… right click shortcut ‘Configure > Runner options’ and on ‘Wine version’ select ‘lutris-GE-Proton8-14-x86_64’).

2)Now on the ‘Game options’ tab in Lutris on ‘Wine prefix’ type in, for example, “/home/user/CyberPunk/” (without the " and swap ‘user’ with whatever yours is setup as) and click SAVE (in upper right hand corner which is green in color). note: that will create a ‘CyberPunk’ folder in your Home directory and your saved game data etc will be stored in here.

3)Try starting the game.

I am just assuming you already created a basic shortcut to the games exe on your hard drive through Lutris.

p.s. I did not play around with CyberPunk 2077 much (benchmark and maybe very little into the game at most) but I was getting better performance than that in benchmark roughly a year ago and your system is clearly superior to mine (desktop 3rd gen i5 at 3.5Ghz under a heavy load paired with NVIDIA 1050 Ti 4GB) as mine is running around the minimums for the game. I don’t currently have CyberPunk installed but what I mentioned above is the general idea on getting games setup properly on the limited amount of games I play (call it about 10-15).

Right sorry, I didn’t provide enough information. I’m using Linux Mint 1.2.something and I was using Ge Proton (I just installed it so I’m pretty sure it’s the latest version but maybe not). Also, I didn’t exactly understand what your instructions are asking. So you’re telling me to use GloriusEggroll runner for lutris and select GE proton as the runner for the game and then make sure that the wine prefix has my PC user name in it so that the game data is saving on the home directory which will load the game faster? Is that right, let me know if I got anything incorrect.

I also use Linux Mint, the newest version, which is currently v21.2 (I am using ‘Xfce’), which uses a 5.15 kernel by default (that kernel is from Oct/Nov 2021). one has a option of using 6.2 kernel though through ‘Update Manager > View > Linux Kernels’ section etc, but the Mint team recommends people stick with the default kernel unless there is a specific need to use a newer kernel.

anyways, after installing the GE Proton, Lutris ‘should’ automatically select it for games. but I like to make sure it’s in use, which you can do by right clicking your game shortcut in Lutris main window, then ‘Configure > Runner options’ and on the ‘Wine version’ part to the right of that should show something like ‘lutris-GE-Proton8-12-x86_64’. if that’s the case then over on the ‘Game options’ tab under ‘Wine prefix’ section to the right of that you can manually type in a location, which is where Lutris itself will create a fresh wine data used with the game it’s trying to load. for example… “/home/user/CyberPunk/” (without the " and swap ‘user’ with whatever your system is set to) and then after starting the game in Lutris it will create a ‘CyberPunk’ folder in ones Home directory like I was saying with Wine data created by Lutris itself (this is best since I had issues when trying to get it to use the system installed default wine prefix location, which is “~/.wine” which is not recommended).

then see if it works or not.

but what GE runner do you currently have selected in Lutris? ; GE 8-15 is the newest released about 1 day ago now (I am currently using GE 8-12 (from July 21st 2023)).

NOTE: if you want to manually install a specific GE runner that’s not available through Lutris itself you can do it by going here… https://github.com/GloriousEggroll/wine-ge-custom/releases ; for example you would download “wine-lutris-GE-Proton8-15-x86_64.tar.xz” and extract it to “~/.local/share/lutris/runners/wine” and then when starting Lutris you can select it for your specific game like I already mentioned.

because from what I can tell if a person does not manually set the ‘Wine prefix’, it defaults to using the system installed Wine (at least on manually created shortcuts to games already in a installed state on ones hard drive) which can cause problems (and has for me until I learned not long ago to setup things more properly).

p.s. but since you are using Linux Mint, I suggest installing the newest Lutris using… Releases · lutris/lutris · GitHub ; download “lutris_0.5.13_all.deb” and run it and let it install. that’s exactly how I installed the newest Lutris on my Mint system, which gives you the newest one from May 2023.

I specifically made sure that lutris was using the GE proton runner in the configure settings. I’m not exactly sure what version though although I know it’s pretty new. I’ll try changing the user from “user” to my PC account username later. I don’t have much hope for it though. Thanks anyway

also, I had Lutris starting August 2023 so I’m pretty sure that’s the newest version too.

It’s easy to see specifically which version using the info I posted.

Yeah, exactly. this ensures it’s using only Lutris created data, not mixed in with the system Wine installation (which saves to “~/.wine”) which helps ensure nothing it out of whack.

that made all the difference for me on at least a couple of games I play. like a difference between working and not working level of difference, so it was not a small difference (at least in my case) as when I had issues it was basically not using DXVK (converts games DirectX 9 through 11 to Vulkan) which is critical for some games. even on the stock system Wine, without using DXVK a certain game etc I play outright does not work. but once I manually enable DXVK it works well. basically Lutris simplifies using that etc.

It’s easy to check, you can do it through Lutris menu’s like the three line menu (just to the left of the ‘minimize’) and select ‘About Lutris’.

or from terminal…

lutris --version

Sorry for the questions but I’m not exactly the most knowledgeable on this, but I thought only the wine runner or the system runner needed a wine prefix? I currently have some games running using the wine runner and those have wine prefixes in the files but never the GE Proton runner so I just assumed that the GE Proton doesn’t need to have a wine prefix because it never had that extra step like other runners where they would configure and add the wine prefixes themselves. If changing the directory really has that much of an effect, I’ll try it right now

Okay I tried it and it didn’t work :frowning:

I fear you are a little confused. To help you understand a little more:
1/ Every game (program) should have it’s own dedicated wine prefix
2/ Lutris runners do not need wine prefixes - after (1) above, each game you have (and therefore each wine prefix) can then have a runner assigned to it. This approach just keeps things simple and easy to manage.

So first thing create a dedicated wine prefix for each game and just straight copy each game into the new prefix, change the executable path and wine prefix in the game configuration panel. No registries or like shit in Linux, everything is a portable program in essence. Once that is done go back into the configuration panel and select the runner you want that game to use. Once you have the concept of wine prefix, Lutris runner and what Lutris does clear in your mind it becomes really easy to understand.

I thought the wine prefix was created automatically? I didn’t have to do it for any other game. CyberPunk 2077 is one of the only one’s that gives me problems

Also I didn’t get what you said at all

It’s pretty much like shag00 said (I do mine a little differently, but what he said should still work).

although… I personally do have nearly all of my games using the same wine prefix though to save about 500-600MB of HDD space per wine prefix this way (so instead of roughly using 6.5-7.8GB or so (over 13 games or so) of storage space I kept it down to about 1.0-1.1GB using only two prefixes. although I am confident I could have kept it to only a single 500-600MB(0.5-0.6GB) if I wanted to). but I do have one of my games running in a separate wine prefix.

like on my system, as a example, here is pretty much how I got mine setup…

“/home/user/.RandomFolderNameHere/general” (nearly all of my games are using this)
“/home/user/.RandomFolderNameHere/GameNameHere” (one game is using this)

this way (with the DOT before ‘FolderNameHere’) that folder stays ‘hidden’ in ones file manager. that’s ‘dot’ stuff strictly optional though.

but my actual game data runs from a different hard drive though even though the wine prefix data is stored like what I listed above. but keep in mind I suggest keeping the directory structure like “/home/user/GameNameHere/” because if you try “/home/user/RandomFolderNameHere/GameNameHere/”, Lutris v0.5.13 (from May 2023, which is currently the newest version) will fail to work as it seems to have a issue creating two folders deep.

like for example…

this will fail to work… “/home/user/RandomFolderNameHere/GameNameHere/”

but if you manually create that ‘RandomFolderNameHere’ through your file manager etc in advance, then that exact same example will now work.

bottom line… if that sounds confusing, that’s why I just told you (the OP) to use “/home/user/CyberPunk/” as Lutris won’t have any issues doing that (and you can run the game data itself from any random location in your computer as I run mine from a different hard drive separate from my boot drive).

Basically you want Lutris to create it’s own wine prefix and you DO NOT want to use the system created one located at “~/.wine” (as that can cause problems as it did for me on at least two games I play until I learned basically what I typed below). so to do this…

Open Lutris, on the CyberPunk shortcut you created (I am just assuming you already got a shortcut there and it’s starting the game through the games main exe) right click it, select ‘Configure > Runner options’ and make sure something like ‘lutris-GE-Proton8-12-x86_64’ is selected. then with that same window open, now click the ‘Game options’ tab and on the ‘Wine prefix’ section type in “/home/user/CyberPunk/” (without the " and swap ‘user’ to what ever your system is setup as. this is important!!!). then click the SAVE (green in color in top right area of Lutris).

now try starting the game and see what happens is the basic idea. that’s THE first thing I would do as it should work, at least it does on my NVIDIA GPU (1050 Ti 4GB) running the NVIDIA v525 driver on Linux Mint v21.2-Xfce.

All that’s really helpful but with “home/user/Cyberpunk”, do I make the CyberPunk file or will Lutris automatically create one for me? I just created a new folder in “home/user” named CyberPunk anyway and made the wine prefix directory “home/user/Cyberpunk” (the folder I just made).

When trying to start the game, an message pops up telling me “Invalid Wine prefix path /home/**************/CyberPunk, make sure to create the prefix before saving to a registry”. The "*"s are to blur my actual user name. I have GE Proton 8-14. The game ran before when I didn’t have anything for the wine prefix but now it doesn’t with that message. Am I missing something?

I am pretty sure I found your problem… you are using the ‘Steam’ version of GE Proton (i.e. github[.]com/GloriousEggroll/proton-ge-custom/releases ), NOT the native Lutris one that I use (i.e. github[.]com/GloriousEggroll/wine-ge-custom/releases ). generally it’s best to use the native GE runner for Lutris over the ‘Steam’ based one.

because recently I had to use the ‘Steam’ GE Proton (on Lutris) on a specific game because it could not run a ‘PeacockPatcher.exe’ (basically Hitman v3.160 paired with a, lets say, “offline” Peacock Server etc) in the native GE runner for Lutris but it works in the ‘Steam’ version and I also experienced that same error when using that trying to create fresh Wine prefix data as apparently the ‘Steam’ version cannot create the data for you, but the native one can. so switch over to the proper GE runner for Lutris and then you won’t have the issue creating “/home/user/Cyberpunk/” solely from Lutris itself.

p.s. because on the Hitman game thing, I had to use the GE runner made for Lutris to create the Wine prefix data first, then switch over to the ‘Steam’ version for things to work. normally the native Lutris runner works, but apparently there are exceptions where the ‘Steam’ based GE runner works and the native one does not.

huhhhhhhhhhh WHAT

I mean I installed the proton GE from inside of the official Lutris program. Where would I even install the Lutris GE proton runner? And why would the official Lutris app install the steam version of Proton GE? Sorry lol, but thanks a lot for trying to help me.

I checked and there’s loads of wine versions you can download in the Lutris Program. I picked GE Proton 8-14 but there’s also “wine ge” and “Lutris GE Proton8-15”.

Based on that it ‘should’ be the correct one.

But on the Github link, the one made for Lutris, you simply extract (for example… “wine-lutris-GE-Proton8-15-x86_64.tar.xz”) to “~/.local/share/lutris/runners/wine” (even the one you download from within Lutris goes to that location) and then you can select this from within Lutris… right click game shortcut, ‘Configure > Runner options’ and on ‘Wine version’ section select it.

but like I say that ‘Steam’ one I am currently using for Hitman with a “offline” Peacock server etc, I installed a little differently. inside of “GE-Proton8-15.tar.gz” for example is “/GE-Proton8-15/files/” and you basically extract the ‘files’ folder to “~/.local/share/lutris/runners/wine” then go to that location and find the ‘files’ folder and rename it to more of a proper name, say “GE-Proton8-15” and then in Lutris itself it will show up as that… right click game shortcut ‘Configure > Runner options’ and on ‘Wine version’ I simply select ‘GE-Proton8-15’ to use that ‘Steam’ version on Lutris. but like I say, chances are the standard one made for Lutris will work fine for Cyberpunk.

even when you download it through the Lutris program itself, it goes to that location as you can check that location currently if you wanted.

But a moment ago I checked from within the Lutris program itself and mine are listed precisely as "lutris-GE-Proton8-15’

but I do see a recent one that shows as ‘wine-ge-8-17’ from within Lutris itself. but I have not used that one as the “8-17” I did play with from the Github site (the GE runners made specifically for Lutris) are listed like “lutris-GE-Proton8-17” after it’s installed.

but just to make sure your Lutris is the newest run the following in terminal…

lutris --version

mine shows…


just to make sure you are on the most recent Lutris.

HOLY CRAP IT FINALLY STARTED WORKING. I still didn’t actually update Lutris. I just installed the “Lutris Proton GE 8-15” runner and picked it in the runner options for CyberPunk AND IT STARTED WORKING AND DIDN’T GIVE ME ANY MAJOR LAG SPIKES although I’ve still only went as far as the start menu so it still could start lagging a lot again. It showed a popup message letting me know that it was updating the wine prefix in the directory I selected for the wine prefix.

Thanks a lot for all the help, I really appreciate it. I don’t think I could have figured it out on my own. Apparently the problem was that the wine prefix directory was left blank in the Lutris game options and had to be in “home/user/CyberPunk”? Which I’m still not sure why that would be the case and also that I had the “wrong” version of Proton GE installed apparently.

I’d still like an explanation as to why a game would need to have it’s wine prefix directory specifically set in “home/user/CyberPunk” and why it can’t just be left blank or set to another file directory? was setting the directory to “home/user/CyberPunk” mandatory for it to work or could it have been any file directory?

Yeah, it’s pretty much what I was saying… download Lutris GE runner and make sure game shortcut is using it, set the custom location for the wine prefix data, and then you run the game, it creates it’s own wine prefix data in the location you set, then you play.

You can set a different location if you like. I just told you that since I know Lutris won’t have issues in that specific location.

as for why it (Configure > Game options’ and on ‘Wine prefix’) can’t be left blank… because Lutris seems to use the system install Wine location (i.e. “~/.wine”) if you do that in my experience which is not recommended apparently as I only learned of that about a month ago now from I think it was user ‘jhu’ on these forums (so a big thanks to him). because once I did that, it solved a issue I had with two games I play as it went from not working to working as apparently DXVK etc can get out of whack with the system installed Wine since it’s always shuffling around stuff when you run ‘winecfg’ from terminal and then when you go to run it in Lutris it rewrites stuff there etc and can cause issues.

but with ONLY using Lutris, which is what “/home/user/GameNameHere/” does, it runs it’s own separate wine prefix there separate from the system installed prefix and things tend to just work this way as it’s setup how Lutris like it. that’s the basic idea.

p.s. one thing I noticed is the ‘Time played’ on your game shortcut don’t get updated on Lutris if you use “/home/user/GameNameHere”. but if you use “/home/user/GameNameHere/” it works as it should.

That’s kind of why I make some posts here and there as that stuff is not obvious for a casual user trying to get this stuff up and running in a more proper way on Linux.