I want Lutris to auto-load banner images, without my being synced to an online store

I’ve been using Lutris to play Windows games for about 4 months now.
All of the games in my Lutris were installed without using a Lutris.net installer, and are not from Steam/Epic/Humble Bundle.

In a two-week period, I had connected to humble bundle account. Or was it the Epic Games store? I don’t remember which. But the point is that I connected to an online store. It was in this time that Lutris automatically loads up the banner images for the “home page” of Lutris.
It didn’t do it for all games, mind you, but it did for some.

But now that I disconnected the connection to the store, Lutris no longer auto-loads images.

How can we get Lutris to load banner images without connecting to a store?.

1 Like

What worked for me was to have a lutris account and add the games I had into my account there. Then it would load the banners correctly

1 Like


I have a same problem…ok…Lutris loads images from account but before the update to 0.5.10. I could load image from my drive and not from lutris account.
Is there a solution for this and is there a chance to be solved with new version?


Hi Owo,
My lutris account all this time is synced to the Lutris program on my computer.

You suggest adding the games to your account? Where exactly do you do that?

Yes, I think I’m in the same predicament as you (axillios). I’m on Lutris version 0.5.10, and no loading of images.
I think it loaded some images before I upgraded to 0.5.10.

Version before 0.5.9 did load images without having to use connected account.
I was never connected to account, I have images in my Pictures folder and it was always loaded.
Hope they fix this. I love Lutris

Huh? You had to downloaded the images into your Pictures folder first?

I collected images over the internet. I have my own collection of game images… When I install a game and when you go to configure there you click on image and add it from your drive… No need for account connection…but after update to version 0.5.10 that don’t work.
To be correct it don’t work on 600x900 px images or artwork images. When you zoom out to make smaller images like it was on version 0.5.9. everything works and images I added for a game it shows. Only when you want bigger images then it’s blank and only works when you connect to your account… And images are loaded from Lutris site only

that’s exactly what I do, depending/waiting on Lutris is just to hard.