I can't select the correct .exe file to "Install a Windows game from an executable" [SOLVED]

So, I’m trying to manually add a game to Lutris using the “Install a Windows game from an executable” tool. However, every time I get to the section where I select the installer executable, the file either doesn’t show up or Lutris won’t let me select the file.

I know this worked in the past because I did the same thing to two other games of mine, but now this feature isn’t working anymore.

Did a recent Lutris update break or disable this feature?

Newest version of Lutris is v0.5.16. is the game already installed? ; if so, just add the games main exe to Lutris by clicking the “+” sign in top left corner and then click ‘Add locally installed game’ etc is the basic idea.

No, the game is not installed. The problem is that Lutris isn’t installing the game.

To my knowledge, the purpose of the “Install a Windows game from an executable” option is that Lutris launches the .EXE installer, automatically sets up WINE, and adds said game to my library.

Yes, I could install the game via alternative methods and “Add locally installed game”, but that isn’t what I’m looking for.

I want to know why this specific feature isn’t working on the Lutris launcher.

I ran i quick test right before editing this, the feature still works as expected (tested with setup_gog_galaxy.exe and EpicLauncher.msi). Might be somethings wrong with the file you select or the path, but not with Lutris.

What about “Download cache configuration”? I get to the step where I pick the game installer, but no .exe installer files show up. I open the “Download cache configuration” to pick the directory my .exe files are located in. But when I do that, Lutris keeps resetting the directory path back to:

/run/user/1000/doc/weird directory name

Although this directory also has my .exe files in it, the files still down’t show up in Lutris for me to select them. (This isn’t for one particular installer file. I have multiple .exe files for installing games and none of them are showing up in Lutris.)

The download cache is used when your setup.exe starts to download content from net. That’s not the correct path to run the executable.
Simple steps:
Run Lutris
Pick ‘install windows game from exe’
type name of game/app (if it matches Lutris database appropriate icons get loaded)
click install
click again install (for wine)
click continue (or adjust installation path )
click three dots next to the text field and select executable (this is different to older versions of lutris)

( lutris 0.5.16 on my rig)

i remember on earlier versions, that ‘configure download cache’ was placed a bit too prominent on the page :smiley:

don’t fiddle with download cache and you should be fine.

I’m running Lutris 0.5.16 as well.

I follow the steps you mentioned above. However,

click three dots next to the text field and select executable

I don’t see this option anywhere. It doesn’t let me pick the executable file.

If I just keep clicking “Continue”, I get an error message saying "Failed to retrieve wine (None) information.

So your version of lutris is older than 0.5.16 as mentioned above.

I installed v0.5.14 in a virtual machine. Instead of dots there is a browse button for file selection.

If your version of lutris is older than that i recommend upgrading lutris.

Correction. It is 0.5.16. I made a typo.

Here is a screenshot. There isn’t any option for me to pick the .exe installer file.
I don’t know what that “Setup file” is, but it isn’t the installer.

i told you to click install in my previous posting!
a simple step and you ignored that.
that wine setup is just creating a wine prefix for the game.

I didn’t ignore you, I just didn’t realize the “install” action you mentioned was referring to this step.

Anyway, when I click install, it takes me straight to the “Select installation directory”. I then click “Continue”.

I then get an error message saying “Failed to retrieve wine (None) information”.

Edit: I figured out the problem. It turns out Wine GE-8.25 is not compatible with the new Lutris methods of downloading/installing executables. Installing GE 8.26 and setting it as the default fixes this issue.

I’m having the same issue here. Where previously I was able to select the executable file from the Setup File step, there is nothing for me to select anymore. Clicking Install on Setup File will then prompt me to choose the installation directory and afterwards it tries to install the executable which it will fail since there was no executable file selected. I’ve clicked every button on screen to find the “select executable” thingy to no avail.

1 Like

delete ~/.cache/lutris/versions.json
Should fix the error you have listed here


Confirming that upgrading to GE-8.26 and deleting this file resolves the issue.

created an account just to say thank you for this! i’ve had this problem for at least a month, and despite it being brought up in several places it would get ignored or treated very dismissively as user error.

1 Like