How to update the lutris runner section with manually or by POL installed wine versions

I was hit by the latest update to wine-staging 5.22 which stopped from working. I found 5.19-staging from playonlinux and 5.21 from lutris but I cannot figure out how to get them to work as runners.

All POL wine versions installed earlier show up in the lutris runner section but not the latest one which I need.

Also copying lutris 5.21 into ~/.local/share/lutris/runners/wine/ did not make that version available in the runner section. Choosing the 5.21 directory as custom version also did nothing. Maybe I have to choose a file? Which one?

Ideally I would prefer to update the runner section with both the lutris and POL versions to make them easily available.

Debian 10.

Yes, this is an issue for everybody. It would be nice if Wine had a revert to previous installation button when this issue pops up as it invariably does. One thing you can do is remove the latest wine version with something like sudo apt remove wine-staging ver.whatever and reinstall the older version which is stored as a deb in /var/cache/apt/archives.

I recently thought about how best to avoid this issue going forward and decided on running multiple versions of wine. Wine allows you to run one instance of wine-stable, wine-development and wine-staging concurrently, which is reflected in Lutris, in my case I choose stable and staging. It’s a lot less headache than PoL. There is no re installing programs or creating new prefixes etc involved, assuming of course you created a new prefix for each program.

PoL also only has 1 developer as far as I can see, wine on the other hand has really blossomed in the last 2 years and is providing updates every month now. You might consider development and staging as has been around for a while now.

I could solve the underlying issue by sudo apt install wine-staging=5.19~buster wine-staging-amd64=5.19~buster wine-staging-i386=5.19~buster since I have the repository active. I did not need to uninstall anything. Remember to also catch the 386 package though. I put the packages on hold afterwards.

Edit to answer my own question: It needed a reboot to update the list of runners to choose from. So installing new runners either manually or with POL works fine.

Regarding POL: It’s still the way to go for office applications since there is no support in lutris for non-gaming stuff. I’m feeling with the poor person struggling with POL development, they would deserve some help.

One question remains: If I want to choose a custom runner under “runner option” which file do I need to enter as “custom Wine executable”?

Hello, for your problem, you will find your solution here:

as I said I’ve already solved it. And my questions have nothing to do with but with the lutris interface.

I did read your post a little too fast. But it’s not important, the link could be still useful for users too which will consult this thread for issues with Lutris.

What I’d like to know is what had gone wrong with Wine to break it, as additionally (At least for PlayOnLinux’s copy), Lutris complained Esync wasn’t compatible with 5.22 either. As well as if there’s a bug tracker for Wine to report the bug?

Blizzard Apps need a special patchset which deliberately gets removed by wine developers from time to time - there seems to be an ongoing quarrel about it. Default wine never had that patchset and consequently never worked with Blizz games. No idea about Esync though.
Although gamers are a big user group I think default wine development is mainly done by employees of a company serving professional customers, so they would like to leave game patches to steam or to whoever else cares. This is just my theory though (and I’m not in any way involved and hardly competent enough to understand the underlying technical problems).
Wine-staging developers could use help with game testing. This seems to involve compiling with or without specific patchsets, so if anybody feels competent enough to volunteer …
Here is the bug discussion: