How to set where C: is mounted in Dosbox Runner? (Pool of Radiance Dos Support)

I’m using Lutris with DosBox, trying to get Pool of Radiance the 1988 D&D Gold Box game to run.

The game need to be only one directory deep from C: to work properly. Anything else and you run into the error ‘insert disk 3 in drive c:’ when trying to create a character, upon which you can’t perform any other action.

(You also can’t start the game until you’ve made some characters.)

Using DosBox on it’s own, I was able to mount C: using it’s commands directly into the directory one level of above POOLRAD, the game directory. I can then go in and run the .exe to get the game going, and can make characters without the error.

But I would rather have the game in Lutris among my other games!

When I’m looking in the Lutris Runner options, I can’t see where I would change the settings so as to control where Lutris mounts C: in the DosBox Runner.

Any suggestions about where to look, or if there’s some way I can configure the Runner to suit what I’m looking for?

Here’s my log for running the Pool of Radiance:

Running gamemoderun /home/jason/.local/share/lutris/runners/dosbox/bin/dosbox /home/jason/Games/DOSGAMES/POOLRAD/start.exe -scaler normal3x
Initial process has started with pid 311699
Start monitoring process.
dosbox-staging version 0.75.0

CONFIG: Loading primary file /home/jason/.config/dosbox/dosbox-staging.conf
OPENGL: Pixel buffer object extension: available
MAIN: Draw resolution: 640x480, pixel aspect ratio: 1.00
MAIN: Emulator resolution: 640x480
SDL: Mouse will move seamlessly without being captured.
MIXER: Got different values from SDL: freq 44100, blocksize 1024
ALSA: Can’t subscribe to MIDI port (65:0) nor (17:0)
MIDI: No working MIDI device found/selected.
MIDI: Opened device:none
MAPPER: Found one joystick
MAPPER: Initialized Logitech Logitech USB Keyboard Consumer Control with 0 axes, 34 buttons, and 0 hat(s)
MAPPER: Loaded default key bindings
MAIN: Draw resolution: 640x400, pixel aspect ratio: 1.20
MAIN: Emulator resolution: 640x480
MAIN: Draw resolution: 960x600, double-width, double-height, pixel aspect ratio: 1.20
MAIN: Emulator resolution: 960x720
Monitored process exited.
Initial process has exited (return code: 256)
All children have exited.
Exit with returncode 256

I got some support from a friendly person on the Lutris Discord, and got the game working!

For anyone finding this later, what we did was:

  1. Create a folder in the default Lutris games folder
    (for me:)

  2. Create a folder in that pool-of-radiance folder called ‘c’ lowercase is important!

  3. used a dosbox config file specifically built for the game, called, poolrad_dosbox.config with the autoexec contents at the bottom of the file written as below:

    rem @echo off
    mount c c
    cd poolrad
    rem exit

  4. moved the dos game folder POOLRAD to ~/games/DOSGAMES/pool-of-radiance/c

  5. in Lutris,

a) click the plus sign to add a new game,

b) type in Pool of Radiance,

c) choose Dosbox as the Runner

d) type in released year 1998

e) in Game Options tab, Main File, point it to the Dosbox config file noted above

f) save and play the game!

Important note!

  • That lowercase ‘c’ is very important, it tripped me up when trying this!

In general, if you need to control how Lutris is handling the mounting of the game, this is the overall method:

  1. Create a container folder for the game,
  2. Then create a ‘c’ directory,
  3. put the specialized dosbox config file in the container folder. It will have that config file plus the ‘c’ directory. This config file is where you’ll put the commands to change the directory to the game and run the executable to start it.
  4. put the DOS game or program directory inside the ‘c’ directory
  5. Point the Lutris file at the Dosbox config file as the thing to ‘start’ it,
  6. Play!

Dosbox Config notes: if it was some other program, you’d change the cd command to the proper directory and the .exe command to whatever that game or program needs.