Back to the main site

How to safely update wine version from lutris-5.4 to 5.7?

Hi,

On my “main” PC, I have Lutris installed for some time now. It has this wine version: lutris-5.4 (along with others from the system of coarse)

On my “second” PC, I’m freshly installed Lutris, and it has lutris-5.7 by default. On both PC’s, I have Manjaro KDE installed, and of coarse constantly updated. Lutris verison is 0.5.7.1-1

Is there a safe way to update the lutris wine version on my main PC? I fear that removing and reinstalling Lutris may broke my working EPIC store… That’s quite problematic to install and run.

Not really had any issues going between minor versions. Only major jumps like 3.x to 5.x when the prefix is full of old stuff.

My approach is to clone the prefix directory, add the clone to Lutris manually ( the + button top left ) as a new entry, then choose wine as runner, then the new wine version under runner options. Right click the clone and winetricks first, see if it picks up all the installed features OK, and hasn’t borked the windows version. All being well, launch the clone.

Never had issues with the base epic store, except having to add -opengl on launch manually. I started on an old installed version - the Lutris install script was updated, but obvs my installed version did not.

It is normal that the internal wine-lutris version did not stay up-to-date with the Lutris package?

Btw, at the moment epic store can not be installed with Lutris. It tries to update itself from the net during the process, but nothing is happening.

Not sure what you mean.

All the install scripts currently on the site will use the “latest” wine with Lutris, but they might appear to lag behind if you haven’t updated runners lately, and/or your default is set to an old version.

Allowing “default” to change all games using it could break things, so I guess that is why the behaviour.

Just tried the bottom “Epic Games Store Latest” into a clean prefix and it installs, updates itself, then runs correctly.

4 days ago, I was unable to install Epic store with the official install script, using the default runner (wine-lutris 5.7). It was unable to update itself. At the same time, I was able to install the store on Windows, so I think it was not an Internet problem.

Btw, this is my original problem:


On my “main PC”, the wine-lutris did not get updated with the Lutris package for some unknown reason. Since I was unable to install the Epic store on my second PC with Lutris, I’m a bit afraid to reinstall Lutris.

I will try again installing the Epic store on my second PC today.

Understood. Tag new (or old!) WINE versions in “Manage Runners” -> WINE -> “Manage versions” (the hammer and anvil), click on the one you want, and it should just pull it down. After that, they are in the menu on any WINE runner.

(Yes, I am using XFCE. Yes, it does look terrible. Yes, I am an FPS player so I have to have zero input lag from the desktop compositing in Wayland/Gnome. No, the options to disable it there didn’t work :D)

1 Like

Oh, that’s what I missed! Thank you!

Btw XFCE is cool. I’m a KDE fan, but yeah, XFCE is also good. :slight_smile: