Back to the main site

How to make Lutris read an edited version of an install script?

I wanna install World of Tanks in Lutris but I already have it as a PC Rip on my hard drive, so I moved it to the location described in the script bc I thought Lutris/the script would detect it and proceed with playing. But it didn’t - it began downloading the game from scratch. Then I thought I should download and edit the script in order to forbid it from installing the game anew (which I can do) but then it occurred to me I have no idea how to make Lutris read the edited version of the script. Will drag and drop work with Lutris or do I have to do something else?

You mean it’s an installed version? Then, what you need to do is not install but set up a shortcut to the installed version.
image
Then select appropriate runner (Wine, I guess?) and provide required paths (including a path to wineprefix with settings described in the install script; you can do that for example using Q4Wine and Winetricks).

Or, if you find all of that to be too much work, you can simply use the install script to install from scratch. That means using installer n’stuff. Don’t worry, you can copy your original settings just fine afterwards (or maybe even replace the newly installed version with the old copy if that’s important for some reason.

If you absolutely have to use a local version of an install script, you need to make sure it’s based a full version of an install script (as opposed to what’s displayed in script preview on website). The command is lutris -i <script-name>, you need to call that in terminal. And IIRC you need to provide a path to script rather than just name (so even if it’s in the same directory you still have to prepend ./ to show it’s a path).

1 Like

I installed it eventually (the way I wanted - using the already installed game) and it runs fine except for one thing: there’s no sound. I ran the winecfg from Lutris and chose all available options one by one but still no sound.

I can only suggest to check if winecfg in that prefix produces sound on test. If it doesn’t, then it either a problem in the game… or the game installer actually adjusts something in the prefix that’s needed for sound to work (or installs a dependency like OpenAL, dunno really).

i strugle to do the same if u can help plese ?

If you’re seeking help you should probably elaborate what you’re having problems with