Back to the main site

How to install NDS games in a differend language then English?


#1

I have some old Nintendo DS games that I would like to play again. This works very well via Lutris with the appropriate emulator. The only problem I have is that the DS games are installed in English by default. For many games this can’t be changed after the installation (e.g. The Legend of Zelda). Since my English isn’t that good, the story gets lost quite a bit, this is a great pity especially for Zelda. :confused:

Now to my question. Does anyone know how to install NDS games in a language other than English (in my case German)?

I’d like to thank you for the effort. :slight_smile:

Cheers
Mau 99

PS: I use the “DeSmuME” runner. And yes, the games include the corresponding language. :wink:


#2

I’m just guessing, but… Have you tried setting the LANG variable for the runner? That’s usually how software detects language. (Though it’s likely you’ve already set the system language to yours.)
If that doesn’t work, you’ll probably have to fiddle with DeSmuME settings by hand (the language id can be taken from documentation).


#3

Under which setting point do I have to set this LANG variable?
Is it under these points (see picture) and if so which one?:thinking:

My system language is German, yes. :smile:
The funny thing is that the runner installed Pokemon SoulSilver in German but The Legand of Zelda Phantom Hourglass (and Spirit Tracks) in English. That makes no sense for me… :face_with_raised_eyebrow:


#4


It’s a table you can add rows to.

…I don’t know much about Nintendo DS but in my experience some localizations exclude original language version (either because it’s not possible to support multiplie languages or they didn’t bother), so it’ll be local language only. Well, I also don’t know where you get your games from, so there may be an opposite possibility (that some of your game copies don’t have a local language; in which case none of your efforts to switch language will pay off :smiley:).
There are also games that don’t detect system language and you have to set it up specifically, but I believe it’s a PC-only problem (…probably). On the other hand, your emulator itself might have this problem, which is why I mentioned its config file.


#5

Unfortunately, the setting didn’t work. Seems to be due to the games. But they have a German voice output, because on my tablet they are also in German.
Maybe it is also something else… :laughing::sweat_smile:
It’s funny that when I delete the games and reinstall them, the savegames are not gone. I wonder anyway where they are stored, because even after the reinstallation of the Runner the savegames were still there.:thinking::face_with_raised_eyebrow:

In any case many thanks for your trouble. :blush::+1:


#6

If DeSmuME doesn’t care about system language, you can probably set up a locale explicitly with an emulator option (either by passing a language parameter or by editing DeSmuME config file).

Most console emulators don’t keep saves in the ROM folder, they usually have a folder for configs and saves in user home (somewhere in dotfiles), so deleting the game would be unlikely to affect saves.


#7

Ok, thx. I have not the biggest knowledge about Linux.:sweat_smile: But I love Linux it is so much better than Windows.

I will try it.