Back to the main site

How to install i386 libary libgdk-x11-2.0.so.0

On more question, then I’m going to play games. :slight_smile: Again, on a Steam Deck, n00b, etc. I’ve tried to install The Simpsons Game for PS2 and Outrun 2016 for PSP and both installed fine. However, then I get this error when trying to launch:

The following i386 libraries are required but are not installed on your system:
libgdk-x11-2.0.so.0

I thought I figured out how to add this, but whatever I did got my deck in a reboot loop and I had to reinstall the OS. So, obviously I screwed up and am looking for the correct answer on how to do this. Thanks again for the help!

1 Like

Hi,
Looks like its part of gtk2:
https://www.archlinux.de/packages/extra/x86_64/gtk2
sudo pacman -S gtk2 → should be it. But I cannot realy tell you, dont own a steamdeck yet.

What exaclty did you install on your system?

On an Arch based distro, that would be “sudo pacman -S lib32-gtk2” and you do want to have those libraries if running 32 bit apps/games. That should not b0rk your system, at worst maybe they don’t have the package. You’d certainly already have gtk2

(but I also know nothing about Steam Deck or their package repositories)

I don’t know what happened to you, but the thing about package managers is, if it looks like dependency/conflict resolution is going to break your system, it probably will! :slight_smile:

Don’t say Y to any final steps (in any distro) if a package install wants to remove system packages and it’s not a package that’s actually replacing those things.

i thought this was what I did before. Hmm…tried again and here’s the end of what I got:\

error: lib32-gtk2: signature from “Antonio Rojas arojas@archlinux.org” is unknown trust
:: File /var/cache/pacman/pkg/lib32-gtk2-2.24.33-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

they all came up as unknown trust. I tried to refresh the keyring (pacman-key --refresh-keys) but no dice. Got that figured, with reinstalling the keyring, but now I’m getting read only errors on /usr. I think once I get that figured, I’ll be golden, I hope. Thanks again for the help.

Oh yeah, that’s one thing I do recall hearing about. By default, you’re locked out of system areas. It’s “read only mode”

I don’t know the square root of dick all about this, but:

"What if I want to do more than what’s available by flatpak?

Totally fine, though it comes with several caveats. Make sure you know what you’re doing and be careful about running random commands / scripts you find on the internet - you may get your Steam Deck into a bad state or compromise your data. In addition, anything you install outside of flatpak (via pacman for instance) may be wiped with the next SteamOS update.

With that out of the way, if you are going outside flatpak and need to edit the read-only image, you can enable that with the following command:"

sudo steamos-readonly disable

2 Likes