Back to the main site

How to install both 32 bit and 64 bit Vulkan Loaders?


#1

Hello. My understanding is that for running certain games, one needs both the 32 and 64 bit Vulkan Loaders. I’m running OpenSUSE Leap 15, and i’ve got the 64 bit loader installed. The problem is that the package manager will let me install either the 64 or 32 bit loader - not both.

I’ve got all the 32 bit loader files, but I’m not sure where I can put them without overriding my 64 bit installation. Can I stick them in the Lutris folder somewhere, or edit a config file to search for the 32 bit loader in a different location?


#2

Which Distro are you using ? and also there was a bug which is fixed now that Lutris didnt detect 32 bit vulkan loaders on some distros. Tell me the distro so i can help you with resolving dependencies.


#3

I’m using OpenSuse Leap 15.
Thanks!


#4

On OpenSUSE Vulkan loaders gets installed with the lutris package as a dependency as of last time I used openSUSE all tho I use Fedora. You dont need to install Vulkan Loaders by yourself (you need to do that only on ubuntu and arch as on this page) https://github.com/lutris/lutris/wiki/How-to:-DXVK


#5

From what I can tell, only the 64 bit loader is installed. Lutris has no problem with 64 bit programs, but when I try to use a 32 bit program like battle.net or EA’s Origin, I get a warning that there is no 32 bit loader installed.


#6

It sounds like the bug that was recently fixed. Is your version of lutris up to date?

I never used vulkan on SUSE or fedora. I would think that you can append whatever 32 bit prefix is used on both the vulkan and libvulkan1 packages and see if that helps.


#7

I think I actually do have the 32 bit vulkan loader installed, as it seems to be part of the libvulkan32 package. I think the problem is that it’s still not being detected by Lutris. I’m using the new 4.22 build as well.


#8

The bug has now been fixed, I am using Overwatch using vulkan via Lutris on Fedora 29. And even if the error is still there showing you can always skip the error check by launch it anyway tick mark. Now fedora has included lutris in its official repos and is working great since release of fedora 29. I tried on SUSE before and it failed but not cauz of vulkan but msttf fonts.


#9

On SUSE the bug is still there i tested on VM. I think you can skip by clicking the check mark and then make sure your wine selected is not your system wine use the PBA given by lutris instead. it should work. No problems on Fedora.


#10

@Jatin Sounds about right. @kaosstar try and tick the box that will skip the error prompt. If it still is the same bug the game should run fine(Knock on wood). If it does work file a bug report and let them know this is still happening on SUSE, if the game does not work let us know.


#11

I tried that previously and it didn’t work. Now it does :yum:
I’m not sure what changed, but I was able to play BF1. Battle.net and Origin now run fine.