Back to the main site

How to add command line arguments that go after the .exe in lutris? [SOLVED]

Hi!

How do it do command line arguments?
Like, for instance, enabling console in the game, or some games have special arguments for patches to work (like VTMB’s -game Unofficial_patch) etc.

I tried putting it in the game options, into “Arguments” (below the executable line), but it’s not working.

Like this:

Thanks for reading!

1 Like

Nevermind…
This is the correct way, it just turns out the game wasn’t recognizing the keypress. I had to switch to US layout, then it worked.
So, now i know, it’s under Arguments.

2 Likes

While you’re at it, what wine version and other configs do you use to run VTM Bloodlines? On one machine I was able to open the console with US layout, but on another I was not, whatever I tried. On the one it works, it was installed a year or so before the other one, and it uses an rc version of Lutris Wine, which is not available any more. I might be wrong, but I started to suspect it might have something to do with the Wine version used, and I would appreciate suggestions for where to start from.

Well this particular question was about Redemption, not Bloodlines.
But if you want to run bloodlines, that game works great on Steam. And it does, i played it.

Switch to Proton version 3.16-6, and if you’re using Unofficial Patch, make sure you install it where steam installed the game usually something like
/home/USER/.steam/debian-installation/steamapps/common/Vampire The Masquerade - Bloodlines

Using wine version: wine-7.20 (Staging) - i was able to run the unofficial patch and install it into the bloodlines folder.
Then just use:

-game Unofficial_Patch as launch options in either lutris or Steam.

BUT: The current 11.3 UP doesn’t work for me, i’m still trying to figure that out with the creator, but 11.2 works flawlessly, so use that one if you run into issues.

Sorry for the late reply, hope you’re able to get it working!

Ah, I didn’t notice it was about Redemption…
I’m already playing the GOG version of Bloodlines through Lutris. It only needs an older version of Wine to run perfectly on the machines we have at home, and that’s it – hardly ever any isssue. But I was wondering about the console, because it starts on one machine and not on the other… But I will try to look into the UP version now that you mention it – I didn’t think about it before. Thanks!

Yeah, apparently the 11.3 version works for other people, but not for me.
So might be why it’s running on one machine and not the other.
Good luck!