Back to the main site

How do I sync Steam games on 0.5.8?

Hello, I have a ton of games installed on my second hard drive (which is an f2fs drive) and cannot be recognized by Lutris with the new version. Am I missing something on how sync works in the new version or is this a bug?

See the release notes:

  • Steam games are directly loaded from the Steam API and it is no longer needed
    to sync your Steam library on the lutris website to see all your Steam games.

You have to set your Steam account as “public”.

I’ve done that (had to connect my Steam account to my Lutris account for it to work at all even thought the accounts was Public all along) and now the games appear with the option to “Install”. I can’t launch them through Lutris unfortunately. Also I can’t open any menus on Wayland weirdly (I am on Garuda Wayfire). So am I doing something else wrong?

I don’t know which Lutris version you use but with latest version,you no more need to associate Lutris to your Steam account, all you have to do is to set your steam profile as Public and reload Steam sources.

@legluondunet what @Qushy is trying to say is that in 0.5.8 Lutris no longer sees installed games automatically. Sure it sees all my Steam games through the API, but doesn’t see any games that are installed by default, I have to “install” or “add” them to Lutris by hand now.

Here is the situation before and after logging out of my Lutris account (yes, it’s the same picture).

1 Like

Je crois que je n’ais pas compris, comment on rend son compte steam public ?

Effectivement les raccourcis générés ne fonctionne plus.

I have the same problem. Did you find a solution? And how do you add them manually? When I use “lutris --list-steam-games” lutris is actually recognizing the installed games but in the gui it does not. It is the same with me like Qushy’s post.

I have the same problem. New installed Steam games do not show up in Lutris automatically like they did prior to 0.5.8. My Steam profile and my Steam “games” details are both set to public. On Lutris.net, under My Library, I see my new game listed, but it doesn’t show in Lutris app.

Are we supposed to install them manually now? If so, how?

Thanks,
phlepper

greetings all does anyone know a fix for this i have this exact same problem under lutris-0.5.8.1-1 i can get my steam games to show up by setting the steam profile to public however all my games say install although some are installed(SOLVED i just hit install on one of my already installed games and i was able to launch through lutris)

Hello, install the latest Lutris version out today, should be resolved.

Not for me. I tried deleting ~/.config/lutris/ and ~/.cache/lutris/ with no effect.

1 Like

Same for me, really strange so lutris does recognize the game. Is there a command so somehow force a sync?

Lutris Version: 0.5.8.1