Back to the main site

How do I install Overwatch on Ubuntu 16.04?


#1

Hey! I just found this Overwatch Lutris. I made an account, I downloaded lutris, and I hit install on the website. Well, in the end, when I hit Launch Overwatch , I get a message

The file /home/boneshiver/Games/overwatch/drive_c/Program Files (x86)/Battle.net/Battle.net Launcher.exe could not be found

I am a newbie who just switched to Linux. I would really appreciate if you could explain me what I have to do. I heard I have to install blizzard app first? I hope you wouldn’t mind to write some instructions for me. Please! :slight_smile:

ps: Is my first topic, I hope I got the right path…


#2

As noted below the installer of Overwatch on the website, you need to install certain dependencies in your system first, here is another page where that stuff is listed:


#3

Okay, I will tell you if it worked when I’m home. Thanks!

Anyone who still reads, feel free to share your experience ! :smile:


#4

UPDATE:
I installed those dependences, and the installation was successful but, when I hit launch, it actually don’t launch anything. I just get a “playing overwatch” message in lutris app, but no actual blizzard app or game opened. What can I do?

UPDATE.2: Nevermind, I re-read the link sent by Dox (thanks mate) and now it’s working. I hope. I mean, the blizzard app shows up, but I can’t connect because Blizzard is under maintenance right now. I will keep you in charge! :slight_smile:

UPDATE.3: It’s downloading the actual game! ^^
UPDATE.4 FINAL: It’s working! ^
^ A bit laggy, I hope it will get well in time. I heard is normal to be laggy for some matches at fresh installation


#5

Yup, shadercache being filled. You have to do that from time to time. Just play.

Oh and make sure you have Nvidia 390.25 driver if you have Nvidia.


#6

yes, I use the 390.25 driver. It’s becoming better and better (or maybe my brain just get used to it). I hope in a good day, Blizzard will develop support for OpenGL (or maybe Vulkan)


#7

fun fact: on WoW they actually did support OpenGL for a while before dropping it again.
also, to quote pretty much everyone else in the business: it doesn’t make any sense for new games to run on d3d instead of vulkan.
so at least there’s hope they’ll catch up to that at some point and/or MS might actually drop new d3d development when enough studios switch to vulkan.


#8

Hi, Ubuntu 16.04 user here.

I installed all the dependencies - double-checked that they indeed installed - no errors. Same result - battlenet folder is completely missing after install process.

To be honest I was happily playing Blizzard games on this machine through playonlinux install,
until the problem started around April 19 or 20, when battlenet launcher didn’t start and froze up the whole pc.

PS. I removed purged everything wine winetricks playonlinux related, before proceeding with Lutris & dependencies install.

Long story short - non-existent battlenet install… - it’s either them or…