How can I change directories in Lurtis? I would like to allow Lurtis to install the game on an external drive

How can I change directories in Lurtis? I would like to allow Lurtis to install the game on an external drive.

I’ve been working on this through Lutris and Bottles, but I can’t get it to the right place.
need help

I have Arch on one SSD and a 250gb free for gaming on the other one.
but I don’t know how to make Lutris install game on the empty SDD

1 Like

There are two ways to do that. In global settings you can change the default install location for games, and it can also be overridden per game.

Same as last time, create a directory on your mounted drive, chown it to your user and group and use that path in global settings.

Go to the “hamburger” menu at the top right of the Lutris program for the program’s global (default) settings.

1 Like


Hay bud, check this out, I can't get permission on my NVMe.2 
but I can install the game on my normal 3tb HDD 

That sucks I bought the nv.2, so I take advantage of the speed 

so this is the problem

1 the auto mount and permission 

How are you mounting it? Mount it in fstab like a normal hard disk, create a directory on it, take ownership of that directory and use the path to it in Lutris.

I don’t know your device node (find out from dmesg for example)… mine is /dev/nvme0n1p1 because I have namespaces enabled enabled in the kernel for the driver (I don’t know what distributors do with that).

In /etc/fstab, something like:

/dev/nvme0n1p1 /storage3 ext4 defaults 0 2

That’s device node (of the partition, not the device itself), mount point, filesystem type, options, dump parameter, check parameter. 1 and 2 are generally the defaults for a non rootfs mount (1 and 1 for that). I (and most distros these days) use 0 for the dump parameter, because the dump utility is not used much anymore.

mkdir /storage3/whatever
chown -R yourusername:yourgroupname whatever

The path to install games in Lutris settings would then be /storage3/whatever in this example.

It should be no different than using any other drive.

1 Like

here is my fstab

here is the nvme and mount point


yo whats up

so i found the line in fstab mine reads like this

/dev/nvme1n1p2 /mnt/nvme1n1p2 ext4 defaults,noatime,x-gvfs-show 0 1

what should i change ?
thanks man

You shouldn’t have to change that, that should be fine (as long as that’s the right nvme partition device). That’s your second partition on your second NVME drive.

Though… you could change that mount point to a more friendly name. /mnt/games or whatever you want.

Anyway, as is.

mkdir /mnt/nvme1n1p2/yourdirectoryname
chown -R youruser:yourgroup /mnt/nvme1n1p2/yourdirectoryname

1 Like

On second thought, take x-gvfs-show out of the mount options. That does more than just “show” the gvfs heirarchy, it’s what causes that to get automounted with the udisks2 volume monitor in /run/media/yourusername. I see that’s what’s happening in one of your other screenshots there. Take control of your drive, that smoke-and-mirrors crap is good for trouble.

Anyway, make your fstab line something like:

/dev/nvme1n1p2 /mnt/nvme1n1p2 ext4 noatime 0 1

By the way, it doesn’t matter how many spaces you have between parameters, as long as there’s one. Distros usually like to pretty it up in columns, but it doesn’t matter. Also, as soon as you specify one mount option, it’s no longer “defaults” (that’s another silly thing distributors do… it’s defaults unless you override them. If I were not having any mount options, I’d put defaults there, but I’m always using at least noatime. Multiple mount options are comma delimited as shown in your original line.

1 Like

One more item of backround info that should be covered here.

The directory you are connecting a mount point to has to exist. For example, there needs to be a directory under /mnt named nvme1n1p2 for that to work.

Mount points are just normal, empty* directories, with normal permissions, owned by root

  • if not empty, you will lose access to any files in it while something is mounted there.

You don’t have to use /mnt, for example if you were to create a directory named games off your root filesystem, you could use that in fstab as the mount point. Su to root or preface the command with sudo

mkdir /games

Then, the fstab line could become:

/dev/nvme1n1p2 /games ext4 noatime 0 1

Just make sure you have a directory on the volume owned by your user (if you already created and chowned it, it will still be there on the drive and you’ll just use /games/yourdirectoryname for installing games etc.

1 Like