Hot Wheels: World Race (2003)

I tried installing a few games from myabandonware and all of them worked, except Hot Wheels: World Race (2003). I talked to the person who did the repack and we tried debugging the problem, but it was clear to them that this is a problem on Lutris’ part. I really need help for this, this game is really important for me.

Here is the output of the submit-issue: Ubuntu Pastebin

Here is the output of lutris -b: Ubuntu Pastebin

Any help would be greatly appreciated :slight_smile:

lutris-error

Hi,
A bit premature judging Lutris as the cause - what you posted looks like the game EXE inside WINE giving you an error. It is possible that the Lutris installer needs updated configuration, so let’s work on that.

…that said, I don’t see an installer for the Windows version of Hot Wheels: World Race - only console emulated versions. Could you please share what install process you used?
I tried to install it off the ISO from myAbandonWare, but it flags the CPU “not compatible” and refuses to proceed…ah, the bad old days of devs being told to include bespoke hardware checks (on the pretense it might save 1 support ticket) :slight_smile:

Is it sharing a prefix with something else? Given the game’s age, the prefix might need tweaking.
I’d manually install the title into a clean prefix, apply the NoCD supplied by myAbandonWare and see if you can get it running with the basics - DXVK, keyboard only (no joystick plugged in) etc.

Edit: I installed this into a clean 32-bit WINE prefix (staging 9.12)
Tried the LGU Release download. That installs okay but fails with the same error you had, also both of the configure tools graphics and controls - crash immediately when launched. Needs more debugging of the Windows tools to find out why, and if there is something that can be done to support it.
Sorry, not what you want to hear, but as I said… not Lutris’s fault